Jump to content
  • 0
AnaRF

Display Flashing and Changing Colours

Question

I've just purchased a new laptop (HP Spectre x360) and have suddenly encountered a problem that with Vectorworks that I have not experienced on my previous machines (despite this one being much better and having a far better display/screen resolution). The screen, seemingly without reason, started flashing and changing colour. This is only on the area of the screen that is used for drawing- the surrounding control panels and palettes are unaffected. And equally, it is fine when I minimise the window or switch windows. I am attaching some videos of the problem to this post. 

Any ideas would be greatly appreciated!

I am using Vectorworks 2019.

 

Share this post


Link to post

9 answers to this question

Recommended Posts

  • 0

Reply back with the dxdiag file from that machine please, I can take a look: 

 

Share this post


Link to post
  • 0

Change the VW>Preferences>Display>Navigation Graphics to Best Compatibility.

Share this post


Link to post
  • 0
1 minute ago, AnaRF said:


It looks like your machine has two graphics cards, an integrated Intel model which is currently active, and a Radeon RX which is not being used. Normally there is a Crimson or Catalyst control panel accompanying Radeon RX cards, in there you should find settings that allow you to enable the dedicated/high power graphics card. Apologies, on AMD products this menu can change and I am not exactly sure where the switch for it may be. HPs website may also list steps for how to do this on that machine specifically.
 

23 minutes ago, bcd said:

Change the VW>Preferences>Display>Navigation Graphics to Best Compatibility.


This should help in the meantime until you can switch to the other card, then you can put this back to Best Performance.

  • Like 1

Share this post


Link to post
  • 0

I'm also having this exact same issue in a drawing on my new laptop.

I have an Intel UHD Graphics 620 card. the file I'm working on is a small 3D house, the file size is currently at 26mb. Today is so much worse then it was yesterday as I could close the document, re-open and the flashing would stop for a least a couple of hours. Today its flashing as soon as I flyover the model even after closing and re-opening multiple times.I have a few external wall textures in the drawing but nothing too elaborate.

Its impossible to work on it when its doing that so any advice would be greatly appreciated!

I've attached my DxDiag too @PVA - Jim if there is any chance you could take a look? 

Thanks

 

DxDiag.txt

Share this post


Link to post
  • 0

Check the cable to the computer /monitor.

Sometimes just re-plugging it helps to stabilize things.

Share this post


Link to post
  • 0

@bcd thanks, its definitely not the cable or monitor - its only the workspace / sheet space flashing and changing colour. The rest of the program remains normal (exactly like AnaRF's problem)

Share this post


Link to post
  • 0

@turnerhoskins The issue shown in the original videos is caused by a graphics card issue. At least for the original post, the issue was (likely) caused because their Vectorworks was launching with the Intel card as opposed to their AMD card.

 

In your case, it appears your machine only has the Intel 620. There are a few things we can try that might assist with this issue though:

 

1) The Graphics Drivers currently installed are from 2018. You could try updating to the latest drivers.

2) In Vectorworks, you can try going to Tools > Options > Vectorworks Preferences > Display > Navigation graphics - Set to Best Compatibility.

3) From your diagnostic file, it appears you are running two displays. I would try disconnecting the second display and seeing if it works with a single display.

 

Looking online, it appears the model of laptop has an optional AMD graphics card. Did you get a model with the AMD card? (I don't see one listed in the diagnostic)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×