Jump to content
  • 0
rebeccac

Issue with Text in VW.

Question

Since i upgraded my OS to Mojave, i am having BIG issues editing / creating text on my VW files. I get the wheel of doom for at least 2/3 seconds every time i try to edit / move / create text. Everything else is working normally so i don't think it is an issue with my computer, but the compatibility with the new OS on my Mac. Can you offer any potential solutions? At the moment it has become so frustrating, i can't really use VW. Thanks. 

Share this post


Link to post

8 answers to this question

Recommended Posts

  • 0

What version of VW?  Only the latest service packs of 2018 and 2019 are compatible with Mojave.

Share this post


Link to post
  • 0

Is the text on a design layer or a sheet layer? I have the same issue in VW 2017/2018 and to a somewhat lesser extent in VW2019 on sheet layers. Turning off all snapping to objects and if on a design layer setting the snapping to other layers/classes off (i.e. set the layer visibilty to active layer only or show others but not to show/snap others and set class to show others but not to show/snap others) may help to speed things up.

Share this post


Link to post
  • 0

Thanks for your responses which are very helpful. 

I am using VW 2017 - it happens on both design and sheet layers.

I might just have to upgrade, though first i will try out turning off all snapping to objects and let you know if this helps. 

Share this post


Link to post
  • 0

What may also help is to turn off the visibility of design layers that have lots of objects/nodes and you don't need to see when working with text.

 

My guess is that VW is detecting objects and trying to figure out possible snapping/tracking options which does slow down VW. The more objects there are visible and available for snapping the longer the snap/track acquisitions/calculations take and the slower VW gets. It is not just with text but also with selecting and moving objects.

Share this post


Link to post
  • 0
On 2/13/2019 at 10:56 AM, rebeccac said:

I might just have to upgrade, though first i will try out turning off all snapping to objects and let you know if this helps. 

Even though VW 2019 isn't as bad as VW 2017/2018 when it comes to this you may still experience the issue as being aggravating more often than not.

 

The "crazy" thing is that with the same drawing in VW2016 you won't experience this lag at all, it will be much more responsive than VW2017-2019 in this particular aspect. The VW graphics engine got a major overhaul in VW2017 and improvements were made in 2018/2019 but there is something in the new graphics engine that causes this. VW staff has been tracking and solving some of the issues causing lags but not all have yet been fixed.

 

Not everyone seems to be suffering from this so I guess there is a hardware and/or (graphics) driver factor involved as well. So upgrading to 2019 while remaining on the same hardware may reduce your issue but whether it will be fully solved in your case is something you probably can only find out after the upgrade has been made.

Edited by Art V

Share this post


Link to post
  • 0

Thanks ArtV - turning off snapping has definitely helped - it is still slow, but not as slow.

I will look into hardware issues i might have - had wondered about that. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×