Jump to content
  • 0
line-weight

Can't edit mesh objects properly

Question

I can't seem to edit mesh objects in the way that is shown in he video below. I want to move vertices so that all of the polygons that share that vertex are adjusted.

 

If I double click on the object I am taken into a group of 3d polygons which I can only modify individually. In other words moving a vertex only affects one 3d polygon, and it becomes detached from the others.

 

The same happens if I use 'Move: vertex only' in the OIP, manually typing a different z value for a single vertex. It only affects one polygon.

 

 

 

 

 

Share this post


Link to post

10 answers to this question

Recommended Posts

  • 0

You don't have to double click to go into an "Edit Mode"

You will need that only to manipulate repair on a single separate Polygon basis.

 

(*) See Meshes as already being in an "Edit Mode".

Don't even Select them before.

Just start by selecting their desired Vertices by a Marquee Selection.

This will activate your selected Vertices and you can drag them around.

 

((*) which is quite error prone to destroy them accidentally if you have any Meshes

in your Drawing and doing standard Marquee Selection for standard Objects)

Share this post


Link to post
  • 0
2 minutes ago, zoomer said:

You don't have to double click to go into an "Edit Mode"

You will need that only to manipulate repair on a single separate Polygon basis.

 

(*) See Meshes as already being in an "Edit Mode".

Don't even Select them before.

Just start by selecting their desired Vertices by a Marquee Selection.

This will activate your selected Vertices and you can drag them around.

 

((*) which is quite error prone to destroy them accidentally if you have any Meshes

in your Drawing and doing standard Marquee Selection for standard Objects)

 

Thanks @zoomer - but this doesn't work for me. With the mesh object non-selected, making a marquee around one of its vertices does nothing - no vertices are selected.

Share this post


Link to post
  • 0

I just tried before and it did work for me in VW 2019 Mac.

 

Do you have Selection Tool Settings in the middle or right Mode,

which will allow Sub Editing ?

I think there is also an option to deactivate display of blue handles anywhere.

(Do they show for 2D Elements ?)

Class/Layer active and such things ?

Edited by zoomer

Share this post


Link to post
  • 0

I've tried the selection tool in all 3 modes.

Class/Layer are active.

If I select a 2d object, the blue handles appear. But not on the mesh.

 

I'm using VW2018.

Share this post


Link to post
  • 0

I thought about the OpenGL setting not displaying things in "Best Performance" Mode,

which I had already lowered for other reasons.

But it also works for me in "Best Performance".

(And in all kinds of Top Plan/OpenGL or Perspective/Orthogonal Views)

 

Are you sure it is a Mesh ?

😀

 

I tried a simple Rectangle, with Push Option and CMD+ALT+R'ed it.

Maybe that will not work when a Mesh is not water tight or broken ?

Share this post


Link to post
  • 0
6 minutes ago, zoomer said:

Are you sure it is a Mesh ?

😀

 

 

 

That's what it says in the OIP!

 

Tried with rectangle>pushpull>CMD-ALT-R as you suggest ... same happens.

Share this post


Link to post
  • 0

EDIT

In English :

It will work in VW 2019

It will not work in VW 2018 - when in a 3D View with Perspective Mode on.

But it will work in VW 2018 when 3D Views in Orthogonal Mode.

 

 

 

 

Du hast VW 2018 SP6.

Hab ich eben ausprobiert - geht hier auch.

 

Aber Du hast eine Perspektivische 3D Ansicht gewählt - da geht's nicht,

bzw. nur teilweise.

Das liegt wohl daran dass das 2018 Auswahlwerkzeug, bzw. dessen Rahmen,

nicht mit der Perspektive klar kommt. Es deckt sich nicht mit dem was Du siehst.

 

Versuch mal mit einem grösseren Marquee, auch von weit ausserhalb,

auszuwählen. Manchmal findet es einen Punkt 😉

 

Wenn Du von der Perspektive auf Orthogonal umschaltest sollte es gehen.

 

 

In VW 2019 wurde das wohl gefixt.

Auch in der Perspektive aktivieren sich die Punkte sofort, sobald sie der

Rahmen tangiert.

 

Übrigens, Für VW 2018 wird es kein weiteres SP mehr geben.

Edited by zoomer
  • Like 1

Share this post


Link to post
  • 0
19 minutes ago, zoomer said:

Du hast VW 2018 SP6.

Hab ich eben ausprobiert - geht hier auch.

 

Aber Du hast eine Perspektivische 3D Ansicht gewählt - da geht's nicht,

bzw. nur teilweise.

Das liegt wohl daran dass das 2018 Auswahlwerkzeug, bzw. dessen Rahmen,

nicht mit der Perspektive klar kommt. Es deckt sich nicht mit dem was Du siehst.

 

Versuch mal mit einem grösseren Marquee, auch von weit ausserhalb,

auszuwählen. Manchmal findet es einen Punkt 😉

 

Wenn Du von der Perspektive auf Orthogonal umschaltest sollte es gehen.

 

 

In VW 2019 wurde das wohl gefixt.

Auch in der Perspektive aktivieren sich die Punkte sofort, sobald sie der

Rahmen tangiert.

 

Übrigens, Für VW 2018 wird es kein weiteres SP mehr geben.

 

Luckily I know enough German to understand this!

 

You're right, changing projection to orthogonal solves it.

 

Danke sehr!

Edited by line-weight

Share this post


Link to post
  • 0

Oooops,

wrong Forum ...

Good that you could translate it anyway 🙂

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×