Jump to content
Developer Wiki and Function Reference Links Read more... ×
KroVex

If in String - Result not as desired

Recommended Posts

Hi There

I have a Question about the "If in String Node":
The following circuit should me depending on the value, set a prefix, or not.
However, the "If in String" not only outputs False / True, but also the sSub input string. How can I prevent that?
228370415_Bildschirmfoto2019-02-04um11_12_50.thumb.png.9c8d8a81d5508bb94a2b08b15b9bcdfb.png

 

Wohnung_marionette.vwx

Greeting KroVex

Share this post


Link to post

It looks like you aren't getting values returned from your Get Record Field nodes (They are resulting in "<Unknown Value>"), which will affect the rest of your network.

You can see that you have wires coming out of your Filter nodes that have 0 items, which will prevent the network from running correctly.

 

I would suggest looking into why values aren't being returned appropriately from the Get Record Field nodes and going from there.

Share this post


Link to post

I looked into this - there is something wrong with the Get Record Field node - I replaced all of the ones that existed with one from the default content library and the network now works appropriately on my end.

 

I will note, I am using 2019, and am not sure which version you are using (though I can tell it's prior to 2019) so please let me know if you're still having an issue and I will send you a file with a new node in the correct version for you to replace them with.

  • Like 1

Share this post


Link to post

As Marissa mentioned

 

1. Replace code inside "Get Record Field", which is from 2016, use an outdated vs.GetType() command and is not update-ready.

2. I would solve the prefix with the if node:

1436855527_Bildschirmfoto2019-02-05um09_52_25.thumb.png.79610d84dd2a53cd677d9dc6d6bdebb0.png

 

3. I would try to keep the symbol record format workflow. Because it is so much easier to change the look of your stamp. 

4. Uploaded an update of my example here:

 

 

Edited by DomC
  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×