Jump to content
  • 0
Ari Phillips

2D components for Hybrid objects not showing up?

Question

Hi there,  

Having major issues getting any of the 2d components of a 3d symbol hybrid object to show up.

I have followed the basic tutorial and all seems fine until you exit the symbol and then it only shows as a 2d object in plan but not in the other views, such as front or side view.

 

Any ideas how to resolve this please?

 

Thanks

 

Ari

 

Share this post


Link to post

4 answers to this question

Recommended Posts

  • 0

1. That is the way Hybrid Objects work. 2D shows in Top/Plan, 3D shows in every other view.

 

2. VW defines 2D to be Screen Plane objects. If you have a hybrid with some screen plane and some other objects, Screen Plane objects will display in Top/Plan and not other views. Layer Plane (or Working Plane) objects will display in all views other than Top/Plan and not in Top/Plan.

 

Depending on your workflow, just changing the objects to fully 3D by changing the Screen Plane objects to Layer Plane may get you what you want. If not, you may need to duplicate the "2D" portion and have both Layer Plane and Screen Plane objects so you get what you want in all views.

Share this post


Link to post
  • 0
6 hours ago, Pat Stanford said:

1. That is the way Hybrid Objects work. 2D shows in Top/Plan, 3D shows in every other view.

 

2. VW defines 2D to be Screen Plane objects. If you have a hybrid with some screen plane and some other objects, Screen Plane objects will display in Top/Plan and not other views. Layer Plane (or Working Plane) objects will display in all views other than Top/Plan and not in Top/Plan.

 

Depending on your workflow, just changing the objects to fully 3D by changing the Screen Plane objects to Layer Plane may get you what you want. If not, you may need to duplicate the "2D" portion and have both Layer Plane and Screen Plane objects so you get what you want in all views.

@Pat Stanford 

Share this post


Link to post
  • 0

Hi Pat,

 

thank you for answering, however from what I understand you can create hybrid models and objects to show as 3D objects in 3D space such as in perspective views etc. But if you want to show the same object in a plan or elevation it shows as simply 2D objects which I have created in the component editor. The issue is these only show in plan view and not in elevations as they are supposed to. I can go into the hybrid object and generate 2D from 3D component in each view, such as front, back and side (thinking this will save time in elevations) but when I come to the viewport or front view it still shows as a faceted 3D model. The only time I want a 3D model in view is in 3D space. 

Dies that make it any clearer? Have I completely miss understood?

 

thanks

 

Ari

 

ps another quick question...is there also a way to convert a section viewport elevation  taken from a clip cube to a editable drawing? Rather than linking with the model? As sometimes we do a rough model to create the basic space and add detail after. Used to be able to do this with sections etc however the clip cube is brilliant and would be great to use this also. Thanks. Ari 

Share this post


Link to post
  • 0

I had a bit of a frustrating time with this as well. I could get 2D components showing up in elevation in some hybrid symbols and not another. turns out the symbol was rotated at 89.5 degrees to the section plane and not a full 90 degrees. Once it was properly rotated it displayed the 2D component view.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...