Jump to content
  • 1
Scook

Is Vectorworks Nomad AR broken on IOS 12?

Question

Hi 

 

I used to use Nomad for displaying Vectorworks models in physical venue model boxes. This worked a treat and on a couple of occasions I scaled the model up and was able to walk a director around the set in the actual venue. However since IOS 12 nomad stutters and ctds within seconds of starting up an AR model.   The standard viewer still works perfectly with no issues however.

I have trawled the forums and web and can find very few references to Nomad let alone any solutions and to date there is only one review on the app store (mine).

Is anyone else using this successfully? Is this a known issue? is it just my setup?

 

Any help with this would be appreciated as its driving me nuts..

 

Cheers

Simon 

Share this post


Link to post

14 answers to this question

Recommended Posts

  • 0

Hi Simon,

From the behavior you are describing, it sounds like you are trying to view a model that the AR engine cannot handle. I would suggest simplifying the model by turning off layers and classes that aren't needed or that contain a lot of curved geometry. If you are willing to share your file, we can take a look and we might be able to identify which objects are the biggest burden in your specific file. You can contact me directly at inikolova@vectorworks.net.

 

Regards,

Iskra Nikolova 

Share this post


Link to post
  • 0

Hi Inokolova 

 

The models in question used to work brilliantly but but now even with simplified models the app stutters and dies in AR. I have attached one of the drawings as an example. Any help on this wouldbe greatly appreciated.

 

Cheers

Simon

Cabaret Nomad.vwx

Share this post


Link to post
  • 0

Hi Simon,

 

I just tested your Cabaret Nomad model on an iPhone 6S and did not see any issue like you describe.

What device and OS version are you using?

 

Thanks,

 

Alex

Share this post


Link to post
  • 0

Hi Alex

Thanks for the speedy response 🙂 

Its an iphone 8 running IOS 12.12 Nomad 6.4.2

I have had a colleague test it on their Iphone  5s and they are encountering similar issues using the test models in nomad. Standard model viewer works perfectly its just the AR viewer that has been misbehaving since IOS 12 update. 

 

I have removed and reinstalled the app, cleared the dropbox folder and transfer the vwx. and then submitted the models for processing again but with out any improvment..

 

Any help is greatly appreciated

 

Cheers

Simon

 

Edited by Scook

Share this post


Link to post
  • 0

Ok I have tested this on an iPhone XS and see the issue you describe. We will debug this today and let you know what we find.

 

Thanks again for reporting this issue,

Alex

 

 

Share this post


Link to post
  • 0

I’m having the exact same problem. iPad Pro 2017

Share this post


Link to post
  • 0

Has anyone upgraded to iOS 12.1.3? I wonder if this might help. We have not updated the AR viewer since November, so wherever the problem lies, it's with a newer version of IOS and certain devices. 

 

This describes the problem well, so it appears others are having the same problem...

 

https://forums.developer.apple.com/thread/113254

 

We will continue to investigate. Thanks for the reports!

 

 

Share this post


Link to post
  • 0

Just a wee addendum, putting the Nomad app into the background does temporarily alleviate the problem but it quickly stutters and freezes until you send it into the back ground again. 

Share this post


Link to post
  • 0

Hi Simon,

 

We'd identified a possible fix to this problem. Would you be interested in installing a build?

Share this post


Link to post
  • 0

Sure I already have test flight installed for some other apps and would be happy to help

 

Share this post


Link to post
  • 0

Simon, 

 

I've sent you an invitation for the TestFlight Beta. Let me know if you have any issues.

 

Share this post


Link to post
  • 0

Hi Alex test flight version installed and initial testing seems positive with no issues. I'll load up some other models and run it for a while. Cheers

for all your help with this.

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...