Jump to content

Recommended Posts

I've been creating 3d symbols.....but in the plan view its shows all the geometry....the symbols i import from the vw library just show a white shape with an outline ....hope you get the gist of what i am trying to do....i think i need the check a setting but can't find out which one   thanks all 

Share this post


Link to post

You need to add the 2d portion. Right-click on the symbol in the resource manager and select edit 2d portion. Add the 2d geometry and exit the edit window. You will now have a Hybrid 2d/3D symbol. 

 

The process has an added layer of functionality in 2019 which you could explore once you’re clear about this.

 

Come back with more questions...

  • Like 2

Share this post


Link to post

i seem to be doing somthing wrong i went to the resource manager and did what you said i am in vw 2017 i have created a symbol but when i go to edit 2d component the symbol seems to disappear.......where am i going wrong  thanks 

test.vwx

Edited by Phil hunt

Share this post


Link to post

in 2017, go into the 3D edit of the symbol, go to the top/plan view.  make sure you are in Screen Plane, and draw the 2D you want to be there.  then exit the symbol.  you will now have a Hybrid symbol.  in 2019 there were some changes made, and you can turn on a ghost image of the 3D to draw over.  

Share this post


Link to post

thanks rob i thought i was doing something amiss.....how do i turn on a ghost image....thanks again 

Share this post


Link to post
6 minutes ago, Phil hunt said:

where am i going wrong  thanks 

You are only in the 2D area so there will be nothing. It's a bit confusing! When you create your symbols it is more often than not best to combine the 2D and 3D together. If you make sure that the 2D stuff is drawn in Screen Plane then that geometry will be consigned to the 2D portion with the rest in the 3D portion.

 

The symbol create command should ask you if you want planar geometry to be converted to Screen Plane and therefore put in the 2D portion, however that is not always what you actually want, so you need to be careful when that warning box appears.

Share this post


Link to post

in 2019, when you go into 2D, there will be a floating bar.  under show other, click 3D, and it will be there and be clickable, just can't edit it.  

Share this post


Link to post

just a question when you have the hybrid symbol in plan view does it save on the screen refresh....or doesn't it make much difference thanks again and thanks mark

Share this post


Link to post

since the 2D is simpler, it would probably save a few miliseconds on the refresh.  Not an engineer so not sure on how much of a save it is.

Share this post


Link to post

one last question sorry rob....created a viewport in plan view using the 2d/3d/symbol and can't get to get a render with just the 2d outlines of the symbol in hidden line or final renderworks,

is this something that cant be achieved.......thanks

Share this post


Link to post

In Top Plan View, the 2D objects will not be visible as the Hidden Line renderer is essentially rendering all of the 3D model and screen plane items (the 2d portion) are not considered to be part of the 3D model.

 

There is a new feature in 2019 which expressly allows this to happen in all of the screen aligned views (Top/bottom. left, right, front, back), but for now you will need to add the 2D portion later as an annotation in a viewport which is laborious to say the least.

 

I hope someone has a more useful workaround........

Edited by markdd

Share this post


Link to post

it looks like top/plan can only be rendered in Wireframe.  I guess you could overlay two viewports with classing of the things you want as 2D only in one and the other having the other items you want in FQRW or Hidden line.

 

but then, I normally don't do too much with Viewports, so I may be wrong on overlaying two viewports working.

Share this post


Link to post

i think you may have to create a shape the same shape as the symbol but extrude it and then place it above the height of the symbol on a different class so you can turn it of when rendering the symbol in plan view in say final renderworks this seems to work a bit fiddly......

Share this post


Link to post

probably a better way to do this......upgrade to v19 !!!!!!!!

 

Edited by Phil hunt

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×