Jump to content
bc

Any Drawbacks to VW 2019?

Recommended Posts

The Architect I worked for just added a couple of the latest tricked out Mac Minis for them to work on. Don't know the specs but I think they are as high as can be.

They run on Mojave.

They currently run 2017 but have purchased 2019 and have yet to install it.

Does anyone have any input regarding their upgrading to 2019?

What would be the pitfalls, if any....anything to be wary of?

I am aware of the obvious better features of 2018 and 2019 and was just wondering overall if there any issues and  if waiting for Service Pack 3 would be advised.

We would be working on new files and not importing from older versions.  I plan on creating new Title Blocks.

Would 2018 be better for them?

Any thoughts would be very appreciated.

Thanks

bc

Share this post


Link to post

Hmmmm.  Doesn't bode well. Thanks.

Anyone/anything else?  (as if that weren't enough)!

Share this post


Link to post

@Gerard Jonker So, if you please,  briefly what are some of the problems can they expect?

 

Is it moving around in OpenGL Walk-through or Fly-over? Or something else?

 

Thanks

bc

Share this post


Link to post

Mainly 3D openGL.

But I would expect that also 2D Top Plan and

Vieports in Layouts (which got GPU acceleration in VW 2019)

may not convince on these Intel UHD Graphics 630.

Share this post


Link to post
20 hours ago, bc said:

The Architect I worked for just added a couple of the latest tricked out Mac Minis for them to work on. Don't know the specs but I think they are as high as can be.

They run on Mojave.

They currently run 2017 but have purchased 2019 and have yet to install it.

Does anyone have any input regarding their upgrading to 2019?

What would be the pitfalls, if any....anything to be wary of?

I am aware of the obvious better features of 2018 and 2019 and was just wondering overall if there any issues and  if waiting for Service Pack 3 would be advised.

We would be working on new files and not importing from older versions.  I plan on creating new Title Blocks.

Would 2018 be better for them?

Any thoughts would be very appreciated.

Thanks

bc

If you are planning to use Mac Minis, I'll suggest you to check some eGPU solutions, because the Mac Minis don't have a good video card.

Share this post


Link to post

VW2019 is unbearably slow and buggy on my new top-of-the-line iMac. 2D is laggy and 3D is nearly impossible. Avoid upgrading, if possible. 

Share this post


Link to post

They already have the Minis (not iMacs) and yes I have suggested they look into the eGPU route per these:

 

https://forum.vectorworks.net/index.php?/topic/59720-egpu-and-vectorworks-testing/&tab=comments#comment-298164

 

https://forum.vectorworks.net/index.php?/topic/60019-so-is-the-2018-mac-mini-a-viable-vw-machine/&

 

Thanks for the replies,

bradley

 

PS actually I was initially wondering about any pitfalls with 2019 (specifically) besides the graphics card.

Any program issues worth waiting for a fix prior to installing?

Edited by bc

Share this post


Link to post

My comment was about software, not hardware. VW2019 has caused endless problems for us on a range of Apple hardware. VW2019 can't handle basic 2D drawings correctly on MacBooks with integrated graphics cards, but all prior versions of Vectorworks ran just fine. Even on our high-end iMacs with dedicated Radeon Pro 560 8GB graphics cards, VW2019 is really slow with basic 2D and 3D operations. Double click a text box to edit and wait for 1–2 seconds for the cursor to become active. Or, extrude three curves and VW will grind to a halt. Or, tabbing through the data bar is no longer a reliable way to enter dimensions. This was not an issue with VW2018 on the same hardware.

 

There may be specific bugs in VW2019 that may or may not affect your workflow, but we've found that general malaise is our biggest problem. I wish that we had stuck with VW2018 for a while longer.

Share this post


Link to post

Thanks ThreeDot, I appreciate the summary.  Looks like you and I are running similar machines.  Maybe the greater RAM is helping with the malaise for me?  I have yet to experienced that. You have indicated it happens even on your high-end iMacs so maybe your closing comment is especially pertinent.

Share this post


Link to post

My iMac is about two years old, but it should be more than sufficient to run Vectorworks. I can run Rhino, ArchiCAD, SketchUp, Illustrator, and other high-end graphics software without any hesitation at all. There is no reason for VW to be so doggy.

 

Do you use project sharing? I've started to notice speed differences between shared and non-shared files.

 

1777383548_ScreenShot2019-01-30at3_35_20PM.thumb.png.5a1476e76803c0ad770b67497bc3f030.png

Share this post


Link to post

I have only worked with Project Sharing on 2017 with another architect about 2 years ago and with no serious performance issues that I can recall.

Sorry, my comments were based on you signature.  You now seem to have the machine I wish I had (aside from the new super tricked out iMacs) or at least could afford.

Now that I see you are running Mojave, I remember reading about issues regarding Mojave specifically:

It may require a day off to read the entire post but maybe this is your issue.

Share this post


Link to post
On 1/29/2019 at 7:20 PM, bc said:

@Gerard Jonker So, if you please,  briefly what are some of the problems can they expect?

 

Is it moving around in OpenGL Walk-through or Fly-over? Or something else?

 

Thanks

bc

I don't know about these two. Just major problems in displaying 2D plans:

- Objects not showing, just selection handles visible

- Objects showing on a different location, Selection handles seem to be in teh right place

- Showing objects that are actually on invisible layers

- Editing a group still seeing objects outside the group even though "show other objects while.." is switched off.

- Plans redrawing not showing the whole plan. Quit VW and then open VW and the file again seems to be the only cure.

Share this post


Link to post

Wow.  Even glitchy 2D. I will be advocating VW 2018 until the service packs sort a few more of these out.

Thanks

Share this post


Link to post

For the most part VW 2019 SP 2 has been reasonably stable on my 2015 era MB Pro (10.10.5 Yosemite).  Some crashes during project sharing.  The space tool has issues with multiple space labels.  Heavy drawing sheets perform better than they used to.  I don't have issues with 2d Display. We do a lot of 3d modeling, and it has worked relatively well.  As always, there are random crashes.  But that's life in VW...

Edited by cberg

Share this post


Link to post

After Sp2 you can go to Vectorworks 2019 without hesitation. It's fast, and it's stable.

At our office we have an underpowered old Mac min, and Vectorworks moves quite well, of course not for large projects. 

 

 

Share this post


Link to post

Gerard- in VW preferences, select good performance and compatibility and see if that solves the issue

Thank you VW Tech Support for the help with this

 

288152460_ScreenShot2019-01-31at7_58_02AM.thumb.png.a74a3d6c9a8d68f75c873d10c272d77b.png

Share this post


Link to post

I have tried all display settings on my computer (again, a high-end iMac with a dedicated graphics cards and plenty of RAM), but it has no effect on 2D or 3D display performance. I mean, I'm sure that I would see the impact of this setting on a complex drawing or model, but our problem is with basic functions.

 

For example, here is a video of a new file with one text object. I double click into the text box to edit (you'll notice a delay), then hit the delete key 15 times as fast as I can. One would expect this simple operation to be smooth and instantaneous. Not so! VW2019 stutters when deleting characters and, at some point, it just stops. I hit delete 15 times, there are 13 characters, but it just stops deleting at some point. This behavior is common with nearly all elements in VW2019. Nothing is fluid. It lurches and jerks through basic tasks, and it makes day-to-day operations really frustrating.

 

@bc Are you having similar problems? Unfortunately, I have not found a workaround for this.

 

 

Edited by ThreeDot
  • Like 2

Share this post


Link to post

- Walls that can be seen in 2D but vanish is 3D (both Hidden Line & Open GL) replacing the walls did fix the problem

- Imported PDF's that can be seen in some Viewports but not in others (Works flawlessly in VW 2018)

- Crashes in some files so frequently I now save every 30 seconds or so

- Imported Image files (eg our digital stamp) that sometimes shows up on the screen & sometimes does not. This is a pain as up until 2019 the default is to have the Stamp grey until the project goes for Permit, but if you can't see the Stamp,  inadvertently check sets have been printed with the Seal active, as it's not visible on the screen, well,  hilarity ensues 

Share this post


Link to post

ThreeDot,

I don't have that problem with text.

I haven't done a lot of work in 2019 but haven't seen any problems on my machine running 2019 SP2 on OS 10.12.6.

When I have opened old files from 2017 into 2019 things get pretty wonky...stuff like JimSmith and Jonker relate.

No big issues with files newly created.

My problem is that THEY are running Mohave.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...