Jump to content
Robert Janiak

Fixture rotation after reopen file

Recommended Posts

Some fixtures has wrong rotation when I save my project in Vision and open it again. If anyone has this bug? Like some information do not save in file.

Edited by Robert Janiak

Share this post


Link to post

I have issues like this as well. But I think it can be anytime you load (esc or v3s). Unfortunately it's so inconsistent that I've hesitated to file a bug report for something not easily reproducible. Majority of the time reloading will solve the issue, so I mostly just deal with it.

 

Here's an example of a show from earlier this week (loading the same esc file).

 

1.thumb.jpg.ea5b792818adfb811f38ed3dff61b29a.jpg

 

2.thumb.jpg.ca71a263001d68e04c27b7be901fd8aa.jpg

 

The reason I took these screenshots is the first time I loaded this esc into Vision, two of these fixtures were oriented wrong. I started hunting around of where I messed up before realizing I just needed to reload the esc and it fixed them. After that I reloaded about 2 dozen times trying to get something consistently reproducible and only got the above screenshot once.

 

Edit: Filed bug VB-157492

 

Edited by LJ TMS

Share this post


Link to post

The only time we have been able to reproduce the issue is when sending a file from Vectorworks to Vision with fixtures that have been rotated but not been focused in Vectorworks.

For conventional fixtures Vision rotates the head of the fixture 90 degrees by default when sent from Vectorworks if it's not focused. Once saved to a .v3s and reopened there  is no default rotation and the fixture may point a different direction if it has not been focused.

This is the only reproducible case we have found and will be working on a fix for the issue.

Share this post


Link to post

Hey Kevin, thanks for the reply. I don't work with conventionals nearly as often as I used to, but I've had this bug occur with led pars & bars, and I'm pretty sure I've seen it happen to movers as well (although I might be misremembering).

 

The above example I was using Elation SixPar 200IP's and rotated with 'Set 3D Orientation' in VW (no focus set).

 

Edit: Also not sure if it matters for this bug, but I always use the 'Export ESC' command (not 'Send to Vision') since I use separate computers for VW & Vision.

 

Edited by LJ TMS

Share this post


Link to post

Thanks for posting this, LJ.

 

If you remember, EVERY fixture - moving and fixed - was spun around when we opened the file on the 2nd computer.

 

Share this post


Link to post
Just now, C. Andrew Dunning said:

Thanks for posting this, LJ.

 

If you remember, EVERY fixture - moving and fixed - was spun around when we opened the file on the 2nd computer.

 

 

Your absolutely right Andy, completely forgot about that! So yea, this bug definitely can occur with any type of fixture.

 

Kevin, I attached the esc file in JIRA (VB-157492) if want to take a look. Although good luck getting the bug to trigger when your trying, lol.

Share this post


Link to post

These 2 images confirm what Kevin said.  "NoFocus" was generated w/o the fixtures having Focus Points assigned.  "WithFocus" was with Focus Points assigned.

 

The challenge, here, is that, within VW, we did NOT want to use Focus Points for these fixtures.  We intentionally wanted them to aim straight-ahead (doable w. Focus Points but would have required 100...)

 

As to moving-yoke fixtures exhibiting this same behavior, we saw it on one computer but not another.  We also saw things flipped 180° (not just 90°) on some loads.

 

WV 2019 Birmingham-NoFocus.jpg

WV 2019 Birmingham-WithFocus.jpg

Share this post


Link to post

I maked simple plugin for add individual focus point to all selected device by Pan/Tilt angle. Plugin take into account 3D device rotation. It helps me focusing conventional devices like Led Par or Led Bar and speed up my work with Vision. Please ask me if you are interesed in testing it.

 

 

 

.
  • Like 1

Share this post


Link to post
52 minutes ago, Robert Janiak said:

I maked simple plugin...Please ask me if you are interesed in testing it.

 

Definitely interested...

 

Share this post


Link to post
On 1/19/2019 at 4:19 PM, Robert Janiak said:

I maked simple plugin for add individual focus point to all selected device by Pan/Tilt angle. Plugin take into account 3D device rotation. It helps me focusing conventional devices like Led Par or Led Bar and speed up my work with Vision. Please ask me if you are interesed in testing it.

 

I'm interested as well, very cool!

 

Share this post


Link to post

Also interested....I just made a rather large post on Saturday that this would help to address.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×