Jump to content
  • 0
GlueDT92

Changing From Decimal to Fractional Inches Causes Existing Dims To Display Oddly

Question

Posted (edited)

In the attached file, the unit rounding style is currently set to decimal, but I want to change that to fractional. However, when I change to fractional my existing dimensions in Viewport 1 freak out & start displaying in strange formats (i.e. 25'-6.25" turns into 2.5520833333333e01 instead of 25'-6 1/4"). Can anyone tell me what's going on & if there is a way to make that change without having to recreate all of the existing dimensions in my file? 

 

Thanks!

Simon

 

Dimensions.vwx

Edited by GlueDT92

Share this post


Link to post

2 answers to this question

Recommended Posts

  • 0

After setting the document units to fractional display, select the dimensions and notice the "Prec" setting in the Object Info palette is blank. Set it to something reasonable and it should work.

 

You might ask why this happened in the first place? Well, It looks like the dimensions were placed using decimal display with the display "Prec" set to the maximum. After changing the document units, it appears that Vectorworks is not assigning it an appropriate fractional value and it remains blank. When this happens, it displays in that format. From what I see, when using decimal document units, keeping the display precision at ".000001" or lower will prevent this from happening.

 

I will report this bug.

  • Like 2

Share this post


Link to post
  • 0
On 1/9/2019 at 9:30 AM, Matt Panzer said:

After setting the document units to fractional display, select the dimensions and notice the "Prec" setting in the Object Info palette is blank. Set it to something reasonable and it should work.

 

You might ask why this happened in the first place? Well, It looks like the dimensions were placed using decimal display with the display "Prec" set to the maximum. After changing the document units, it appears that Vectorworks is not assigning it an appropriate fractional value and it remains blank. When this happens, it displays in that format. From what I see, when using decimal document units, keeping the display precision at ".000001" or lower will prevent this from happening.

 

I will report this bug.

Thanks Matt! This seems to have worked. Much appreciated.


Simon

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×