Jump to content

Vision and Hog connection issues

Recommended Posts



I am having connection issues between the Vision 2019 and the Hog 4 pc running on the same computer. 


I am running the latest Windows 10, the Sp1 Vision 2019 and the latest Hog 4 pc and connectivity software. 


Upon opening the Hog program, I have made sure that the visualizer streaming is turned on.


Opening up Vision and loading the show file, I make sure the dmx is set to Hognet.  When I do that, a small window opens for the Hog Visualizer connection status. It eventually says "unable to connect to Wholehog"


On the Hog software; I have opened up the network window, and the settings for the Visualizer. I try the drop down menu for the Detected Visualizers and nothing appears. I have manually typed in the computers IP address in the top cell and click apply and nothing happens still. 


I have re-installed all the software, restarted the computer, tried opening the programs in different orders, and using new show files with no connection being made


I did not have these issues running vision 2018 and HogPC in the past. Not sure where the problem lies. 


I would appreciate any help in solving my problem.


Thank you, Glen Goodwin

Link to comment
  • Vectorworks, Inc Employee

We ran into a similar problem when testing.

Make sure your anti-virus and firewall are not blocking any processes or communications. There was a change necessary in the way we communicate with the Hog for 2019.

If that is working, make sure you completely uninstall Hog3, Hog4 and all the connectivity drivers and then install Hog 4 with the current connectivity driver.

We think either the Hog3 or the old connectivity driver was causing a conflict for some users.

If you are still having problems please contact support and they should be able to help you resolve the issue.


Link to comment

I am still having connection issues. I have disabled both the firewall public and private, and turned off windows antivirus. I have removed and re-installed both Vision 2019 and the Hog pc4 version: 3.10.0 b1809. 


Running both programs on the same computer; running Windows 10 on a MAC using bootcamp. 


Wifi router generates the IP address for the computer and the Hog software uses that IP address when it fires up. 


Load and start the Vision program first and load my show file. Check that Hognet is selected; Lights are doing random strange flashing, which is a good thing.


Start up Hog 4 and checked the Hognet upon loading to check for DHCP settings, and the Wireless adapter is selected (the only one listed). Checked the visualizer is running in the settings dialog, then loaded a new show (just to be sure my current show is not corrupt).


Go to network window, highlight visualizer (which is running and online) Use the drop down for "detect visualizers" and nothing comes up other than a bunch of "0's".


Have tried to type in the IP for the visualizer to force a connection and still nothing.


I do not see where Vision tells me what IP address it uses, other than assuming it takes on the one from the WIFI Network. The HogPC is using the same IP address too. 


I have tied to use a custom IP for the Hog, using all the same network numbers, but using a different IP address and still no connection.


Have tired turning off the wifi to force a internal computer IP network, buy still no connection


Really at my wits end. It has to be something simple or overlooked in my set up.


Thanks for any additional advice or suggestions.





Link to comment

I use Vision on a Mac and have HogPC running on a windows machine, so I can't really help apple to apples.

Just curious, have you tried setting to FixtureNet instead of HogNet?

Have you tried different subnets in the Hog-Net output window? I had many troubles until I changed the Subnet from 1 to 0.


To help, I suggest taking a picture of each screen as you make changes to settings. I found that I would forget if I had tried things and wasted time redoing the same thing over and over. Once I hit gold, I save the picture of the correct settings.


Best, Scott

Link to comment

I have a slight update.


Instead of trying to work with Vision 2019, I reinstalled Vision 2018. Saved my 2019 file, opened it up in V2018, set dmx provider to Hognet, opened Hog4pc, made sure the setting were correct before loading the show, once the show was running, went to network, and now the drop down for detect visualizers shows the ESP IP connection. Once selected, the hogpc and V2018 are connected and communicate as expected. Both programs are running on the same computer, windows 10, all firewalls and virus turned off. 


So, I have to assume there is something in Vision 2019 which is preventing a communication link to the HogPC.


Anyone have any info which might help figure this out?

Link to comment
  • 2 weeks later...
  • Vectorworks, Inc Employee

Just to add some more information the the thread. We are investigating an issue running in bootcamp with Vision 2019 with HogPC.

We have not been able to duplicate the issue running a standard windows machine.

MAnet and other protocols appear to be fine running in bootcamp.

Link to comment

Thank you for commenting.  I was working with Mark E. on Friday where he took control of my computer and setup. He found that the loader file (located in the vision--dma providers--32 folder) which is supposed to help connect the 32 bit Hogpc to the 64 bit Vision. The Loader tries to start then crashes. Since the app crashed, the connection is not made. Mark spent over 2 hours working on my system trying to make it work, but could not. He copied many error report files and information and was going to ask the engineers to take a look. I would be available for another session where someone can look at my setup and see what might be causing this to happen.


Thanks, Glen

Link to comment

I know. That's what is so perplexing. Not sure what it is with bootcamp which is causing the issue. I never had a problem with previous versions of Vision, but I understand that 2019 is a major re-write and that the Hogpc connector has not been updated to 64 bit, so the small loader app had to be created. 


I would be happy to set up another session for someone to do some more investigation. Contact me directly at goodwinltg@mac.com.


Thanks, Glen

Link to comment

This is a reply from High End Engineers on the forum site


"Hello, we have found an issue with connecting Vision 2019 and Hog4 PC.

It looks like vision 2019 installs an older version of the connectivity driver.

Install Vision 2019 first, then Hog4 PC 3.10.0 and let me know if this fixes your issue. "

Link to comment
  • Vectorworks, Inc Employee

Please let us know if this works for you. I talked to the engineers from HES this afternoon and they are having mixed results.

A clean install of the Hog4 PC after installing Vision has always fixed the problem for us but it's not always working from them.

If you still have problems I may have one of our engineers contact you to further isolate the issue.

Link to comment

Same issue.
Uninstalled both programs, downloaded and installed vision 2019 first, then downloaded and installed Hog4PC 3.10. Opened up Vision2019, loaded show file, made sure Hognet is selected as the dmx provider.

Opened up Hog4pc, made sure Visualizer is checked in the settings window of the startup window. Loaded my show file, when to network--settings--detect visualizer and still zeros. Went back to vision 2018 and it connects fine. Just not what I would like as I would prefer to run Vision 2019.

Thanks for posting your comment and something to try.


I welcome a conversation with your engineers. What is the best way to make contact? 


Link to comment
  • 3 months later...

Hey All,


Stumbled across this thread as I'm trying to resolve what seems to be a similar issue.

- Have Vision 2019 installed (updated etc.)

- Installed a new copy of Hog software today (Version 3.12.0 b2351) on both, my Hog PC and Road Hog console.

- Unable to connect to either my Roadhog 4 or Hog 4 PC (on same computer.)


It's been a while since I've connected the console to Vision, but had it all working in the past.

Console can't seem to find Vision 2019, no matter what I try. (I am able to connect to Vision 2018 successfully from my Road Hog 4.)

- Tried networking through both, Hognet and Fixture net ports (Although, I believe Hognet is the correct port to use)

- Tried different IP ranges (Usually use Static IP's but tried DHCP server today as well.)

- Tried Re-installing Hog connectivity drivers

- 'Run Visualizer Stream' is enabled

- Tried different network cables etc (Again, verified all is working as I am able to connect to Vision 2018)

- Have disabled all firewall's (Both Windows Firewall and Kaspersky Total security etc.)

- Also tried running Artnet signal to Vision instead of Hognet as the dmx provider, no luck.


I'd be happy to assist with further investigation as I would really like to get this resolve.


Link to comment
  • Vectorworks, Inc Employee

@Henslin One of our engineers will reach out to you directly for some more details.

Your physical Road Hog 4 console should connect via Artnet or sACN without a problem.

We have only seen issues with Hognet driver.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...