Jump to content

Clipping problems still..........


Recommended Posts

Has anyone experienced any problems or difficulty using the Clip Surface command?

I am still having problems using this tool at times most recently when using small rectangle to clip another object. I would select as I normally do and after executing the command the clip did not work but it now left an outline of the clipping object in place that can't be delete. It somehow merged the shapes instead of clipping, but not like the Add Surface command does. I save the file, re-booted and reopened and I still have the problem in the file getting it to work. I have posted a previous complaint about this tool and I still have no answer. I can't be the only one that this has happened to.

The file is ready to send to someone for evaluation.

Thanks and Regards,

Tom in PA

Link to comment


Your clipping object doesn't quite overlap the shape you're trying to clip from. If you zoom in very large and set lines to 1, you'll see what I mean.

VW will allow you to clip a shape out of a larger shape (holes on a rectangle, for example). It thinks that's what you're trying to do.

Just make your clip shape larger or move it till it distinctly crosses outside the shape you're trying to clip.

Good luck,

Link to comment


The clipping object is overlapping the main object by .50". This is not the problem. This problem exists with VW11.0 and did not exist in VW8.6. I can take the exact same files and duplicate the clip problem on VW11 and it works without a hitch on 8.6. I have previously sent a clip problem file to Katie for evaluation. Some times you cannot just make the clipping object 'larger'. It just doesn't work that way. If I am working on a mold part and need to clip to close tolerances I can't just oversize the part used to clip because of a software flaw.

Again, this was never a problem in previous versions. What I don't understand is how I can be the only one to notice this issue??


I'll send you the file in question.

Thanks for the support guys,

I'll keep you posted.


Tom in PA

Link to comment

Hi Thomas

I had a look at the file.

I think the problem is because you are trying to clip the main object twice with the smaller rectangles,while still within the shape of the main object but yet outside of it,to those that havent seen the file that sounds mental.

I split the rectangles in half so they were only intersecting the main object once and it worked okay.

I have never found this before tho ,perhaps it is a limitation.

I know its one more step but it is working tho.

hope this is a help

Regards Brendan

Link to comment


I sent you a new file that I just created that clearly shows the clipping flaws. It is two shapes being clipped by another. This works OK. Then I joined the two shapes together using Add Surface and then tried to clip it the same. Bingo! The flaw appears and the clip is wacko. This is truly a bug if you ask me. Can I be the only one do ever do this??


I sent you a copy of the file also.



Link to comment


After you clip the the first two shapes, but before you join them, click on one of them and select the 2D Reshape tool. Click on the shape. Are there by any chance "extra" vertex points. . .more than one at each corner? Also verify by glancing at the OIP: it states the number of vertices.

Then do the same after Adding Surfaces. I've sometimes had additional vertices wreak havoc with subsequent operations.

Keep diggin, we'll find it. . .

[ 02-15-2005, 11:04 AM: Message edited by: Travis ]

Link to comment


Quite possibly.

I think it comes back to the type of shape as well.

Because it recesse internally and the clipping object is intersecting it twice while still inside it ,it goes screwy.

Perhaps its time to submit to bug submit.

I tried going fromt wards and backwards, no fill on one on fill on both,convert the rectangle to a polygon no go.

It worked every time tho when i split the Rectangle then used both to clip the surface.

Sorry but thats the only work around i can think of at this stage.

Regards Brendan

Link to comment

I just re-did the file in VW 8.6 and cannot get the system to fault as it does in Vw 11.0.1. It clips perfectly everytime without regards as to one shape or two shapes.

Also when I use the clip in 8.6 I just use the smart cues and snaps to position the clipping object and just clip. The notion that I have to adjust and reposition to have overlap is ridiculous. Purely a software issue that I raised months before.........Anyone from NNA listening out there.......

Thanks for the help guys,


Tom in PA

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...