Jump to content
  • 0
fhunt

Viewport Class Overrides- not working??

Question

Hello!

 

I am attempting to override class settings in a viewport as per the instructions here:

http://app-help.vectorworks.net/2017/eng/VW2017_Guide/Viewports2/Changing_the_Class_Properties_of_Sheet_Layer_or_Design_Layer.htm#XREF_23286_Changing_the_Class

 

However it doesn't seem to work.

 

As a summary, I have a number of tree symbols that are on the same class, but different fills. In my viewport I want to show them simply all with no fill. I've followed the instructions above but had no luck. Can anyone help?

 

I've tried changing all the original trees to 'class style' in the fill (although not ideal as I still need them to show in different colours on other viewports), and I've tried different options in the class overrides, nothing seems to work. I've used a work-around for now by selecting elements in the tree symbol and using the detail level visibility options, but if I could get class overrides to work it would be a really useful tool! I thought it could be because they're symbols but I've tried other classes too and they don't work either- help!?

 

I'm currently using Vwx Landmark 2019 on mac.

 

Thanks!

 

 

Edited by fhunt

Share this post


Link to post

6 answers to this question

Recommended Posts

  • 0

I don't think Viewport overrides will do what you want based on the way you have things set up.

 

Viewport Overrides only work on attributes that are set ByClass. 

 

Since you say you have objects with different fills, that means that those objects can't have the fill set to ByClass.

 

I can think of some complicated work arounds, but nothing simple to do what you want.

Share this post


Link to post
  • 0

That's really helpful to know, thanks! I've got various workarounds so I'll have to go with those for now.

 

Not sure quite why it didn't work when I changed everything to ByClass for a test, but that might have been the way the symbols were set up!

 

Thanks

 

Share this post


Link to post
  • 0

To get it to work properly within symbols (and other container objects, i.e. groups and PIOs), each of the contained objects also needs to have the attributes set to ByClass.

 

And just for the sake of saying it again, in order for contained objects to be visible, the containing object must be visible also. So if you create a symbol and put the symbol instance into Class A and then make Class A invisible, every object inside the symbol will be invisible also, regardless of the visibility settings of their individual classes.

Share this post


Link to post
  • 0

Pat,

Am I reading this right that if one has a floor slab with components in multiple classes that the viewport overrides wont work as expected? IE: a floor slab with top surface on Component : Wood deck  will mean its impossible to override that one class?

Share this post


Link to post
  • 0

I don't have a lot of time to dig into this right now, and I don't use slabs very much, so someone else might be better to answer your question, but here goes:

 

The short answer is that you should be able to use class overrides on slabs. As long as everything is set up right.

 

Longer answer, I was able to use Textures to override slab settings, but I could not figure out how to get the 2D attributes to show even in the design layer, so I could not check it they were over ridden or not.

 

Longest answer,  Yes, class overrides should work for components of slabs (and walls). 

1. In the Slab Style, the components must be classes so you can override just the ones you want.

2. The components must have the attributes that you want to override to be set to be By Class.

 

Create a new document. Draw a slab and make sure it has a Slab Style of Floor Assy-Wood 2x13.  Create a viewport that shows the slab. Set the view to something other than Top/Plan. I used Right Iso. Set the Render Mode to Open GL and Update the viewport.

 

Click the Class button in the Object Info Palette. Select the Component-Decking (wd) class. Click the Edit button. Go to the Textures Pane and change the Object and Component Textures to something different that it is. Try and pick the most different color just to see the effect. Click OK to close the Edit Class(es) dialog box. Click OK to close the Viewport Class Propertied dialog box. Click the Update button in the OIP.

 

You should see that the object texture will change to what you set as the override.

 

Ask again if this does not work for you.

 

All tested in VW2019 SP2.

Share this post


Link to post
  • 0

Pat,

 

Many thanks for this. The key takeaway (and maybe my fault for not being clear, but only out of ignorance). I was trying to change to solid white. Turns out in over-ride you have to uncheck the Texture box in order for over-rides to work on the Graphic Attributes tab. 

Now we know!

 

-jamie

Screen Shot 2019-01-12 at 4.18.51 PM.png

Edited by techdef

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×