Jump to content

Question

I have been trying to import a large point cloud and I cannot seem to figure out how to get it to the right scale.

 

I have tried every combination of units, both pre-setting drawing units and changing the point cloud import units and nothing I do has yielded successful results. The import has yet to come in at the right scale or x,y,z location.

 

Anybody out there with some tips?

Edited by ericjhberg

Share this post


Link to post

12 answers to this question

Recommended Posts

  • 0

Hi,

 

I can look into this, can you share the point cloud file ?

You can send it to fzafar@vectorworks.net

 

Regards,

 

Share this post


Link to post
  • 0

@zoalord12 I have uploaded a test file to the following sharable link since .las files are not permitted on the forum.

 

https://app.box.com/s/z08lzjey9idopxrizmm1aqzde827m8dl

 

To be clear, this isn't a file specific instance, this is EVERY .las file I have ever tried to work with! When using a program like VRMesh to view the point cloud, it scales perfectly, but VW doesn't come close to matching that, regardless of the combination of document units and import units I try.

 

Any help is greatly appreciated.

Share this post


Link to post
  • 0

So i imported the file (left) and scaled it in half (right), everything seems to work as expected.

Are you using Modify->scale Object ?

 

That is what i use generally.

What are you trying to do ?

scaled_.png

Share this post


Link to post
  • 0

@Fahad Zafar This method flies in the face of traditional drafting practices...NEVER scale survey information! Lidar is survey information and we shouldn't have to scale it to make it work!

 

Again, when used in a point cloud software like VRMesh, there is no need to scale. This means that VW interprets the data differently than other software...inaccurately it appears. This is a big deal for those of us trying to utilize Lidar data as survey.

Edited by ericjhberg
  • Like 1

Share this post


Link to post
  • 0

LIDAR data is generally assumed to be in milli-meters. Can you tell me the difference in scale between the VRMesh import and the Vectorworks import ?

 

I see that VRMesh has different bounding box measurements compared to Vectorworks (see image).

I checked with a 3rd software CloudCompare, and the numbers match exactly with whats in Vectorworks (see image). I changed the origin and set the Units of the Vectorworks page to meters.

 

So now we have a 3rd software matching the import numbers of Vectorworks, and we have VRMesh.

 

If you look closely, they are all the same in all 3 softwares.

 

the bounding box is:

X = 718.55

Y = 380.82

Z = 195.46

 

if you subtract the limits of the VRMesh Bounding Box, you will get the same numbers.

 

 

comparing_vw_with_cc.png

vr_mesh.png

Share this post


Link to post
  • 0

You can go to File -> Document & Settings -> Units

and change units to Meters to get these numbers correctly. Vectorworks is using feet & Inches.

Share this post


Link to post
  • 0

@Fahad Zafar I didn't realize that Lidar data is assumed to be Millimeters? In the example I provided, the units you returned are actually the correct values, but in Decimal Feet, not meters (or millimeters). The bounding box in real life units is 

X = 718.55 feet

Y = 380.82 feet

Z = 195.46 feet

 

If this is true of the units, how do I go about importing it into vectorworks in Feet without scaling the point cloud? Isn't this the intent of the Units selection on a Import Point Cloud Options dialog? The prompt states "Units of the points to be imported." Therefore it stands to reason that the Lidar is somehow unitless and that the Import Dialog sets the units? 

image.thumb.png.980e65854bb456bde130623a2235977a.png

 

It's either that or that the Point Cloud is dimensioned; therefore it shouldn't matter what the document units are or the Import Settings? It should come in 1:1 regardless of unit.

 

FYI...I have figured out how to get relatively close by scaling the Point Cloud by 0.3048 (decimal conversion of meter to feet), but I'm not very fond of this solution because, as I mentioned before, scaling is generally a no go for survey information...particularly because the conversion between meters and feet is a running decimal; therefore, scaling will automatically introduce a level of conversion inaccuracy (granted 4 decimal places is a very low tolerance).

Share this post


Link to post
  • 0

Hi Eric,


Your understanding of the "Units" pop up is correct, if you select it, you should get the data imported in those units. That is not happening for “feet”. I noticed that all the test data we have is actually in “mm” thus this bug has actually passed through some recent changes. Thank you for reporting it.

 

This is the problem:

All the data is being multiplied by a factor of "1000" unnecessarily.

 

This is the workaround (for now, this will be fixed in an upcoming Service Pack):

When importing your data, select "feet" as the units. Once the import is done, scale by a factor of 0.001.

Then reset the origin to bottom left of your data in the "Top/Plan" view to see that your "feet" dimensions are correct and as expected.

 

 

Regards,

Fahad

 

 

 

  • Like 1

Share this post


Link to post
  • 0

I work a lot with point clouds, and it's absolutely imperative to set VW to match the incoming unit prior to importing, so as to get predictable and accurate results.

Scaling after import will always introduce a level of rounding errors.

 

VW can cope with everything from millimetres to parsecs, which is a huge varience.

This is common behaviour across different platforms, and not a short-coming of VW alone. 1 divided by 25.4, resolves to far too many decimal places to be used with the super-accuracy that Lidar data posesses, so get the units right before import....

No harm in abandoning and re-trying if first import goes wrong. Much better than scaling after the fact.

 

  • Like 1

Share this post


Link to post
  • 0
2 hours ago, Fahad Zafar said:

Then reset the origin to bottom left of your data in the "Top/Plan" view to see that your "feet" dimensions are correct and as expected.

 

Here is another problem that exists with scaling data...how can I be assured that the resulting origin after scaling matches the real-world survey x and y coordinates that are embedded in the data. Perhaps more important that the vertical reference, the horizontal reference of this data is imperative.

 

I hope that we can expect a fix of these inconsistencies soon.

Share this post


Link to post
  • 0

Resetting the origin to the bottom left is just a test to confirm to you that the data coming in has the correct bounding box, since the scan points are not 0-based.

If you want to keep the original, then don't change the origin.The origin is just a point of reference.

 

When you scale something and undo the scaling, the origin is preserved. Not only that, the actual values are also exactly the same as the original.

 

Did you know there is a scale factor X Y Z that is part of the LIDAR data header ? 

Reading the data from your file can trigger scaling based on your LIDAR file (see image) per point value.

 

 

 

format header.png

Share this post


Link to post
  • 0

A good point to note is where in space the file will be imported into. The origin is an important factor.

When you're using Geo-referenced data, you'll often find you're way off from the origin, unless you're off the south coast of Ghana.

While VW can cope with data a long way off, you start introducing floating point and rounding errors. This has always been the case.... Get your data as close to 0,0,0 as possible.

 

image.thumb.png.52b291a494e329d7b5a8009295ba276c.png

 

So I tend to export my points as a local co-ordinate system. This helps VW out.

If I need the location data of the site, I draw a grid underneath with the GPS grid manually entered. Not great, but it does work.

 

 

image.png

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×