Jump to content
  • 0
Mark Mosher

VW 2019 and Spinning Wheels

Question

Hi all,

I have upgraded from 2015 Designer to 2019 Designer SP2 recently. Am now experiencing the spinning beachball with increasingly longer spin times as my work continues, sometimes ending with a Forced quit. Almost every click causes the spin. 

Watching muy Console Log while this spinning is happening, I get many many lines of the Message   NSGenericException -- The window has been marked as needing another Display Window pass, but it has already had 3 Display Window passes.

Restarting has no effect, nor did re-installing the application. I am, however, using Batch Converted files [event facility] with all of the same content from 2015.

 

2019 Designer SP 2

27"iMac Late 2015 Intel Core i5 3.2GHZ 16GB Ram 1TB HDD Radeon R9 M380 2GB VRam 

ASUS PB328 Monitor

OSX 10.14.1

 

Any suggestions would be super helpful, thank you.

Mark

Share this post


Link to post

8 answers to this question

Recommended Posts

  • 0

I had the same issue.

Switch back to version 1.1

That´s not really perfect at all, but the ball of death does not appear that often.

To do so - open the Vectorworks Updater, while holding command and option and click on advanced options

i think the last entry in the pop-up is called "change version"

Share this post


Link to post
  • 0

Ugh, sad to report that it is a no-go for me on this potential fix [revert to SP 1.1]. Perhaps others will have additional things for me to try.

Share this post


Link to post
  • 0

VW2015 and VW2019 are very different in how they use hardware. 2GB of VRam may not be enough to run an additional monitor with the VGM upgrades. What is the navigation graphics dropdown menu set to in Vectorworks>Preferences>Display? You might have to change it to Best Compatibility. Are you also using Multi View Panes?

 

Kevin

 

 

 

 

Share this post


Link to post
  • 0

Hey Kevin, thank you for jumping in. I have tried the Compatibility drop down selection as well as do not use Multi-Pane Views.

I have tried a new empty file, same outcome with a few lines and squares. Very strange.

Maybe my iMac specs are too low. SomethIng I can most likely have upgraded..

 

Share this post


Link to post
  • 0

i guess we have a similar machine in our office. if i´ll find the time tomorrow i´ll drop my designer license onto that...

what exactly is a no go?

sp1.1 runs better for me than sp2 does

Edited by bjoerka

Share this post


Link to post
  • 0

Hi bjoerka, 

The no-go is that nothing had improved, same lengthly spinning beach ball after any click. Anyhow, I have reinstalled completely and have not updated to SP2. I shall see where that goes.

Thank you for your help.

Share this post


Link to post
  • 0

I think I have solved my issue. I had 90 Sheets of various viewports [preset room layouts] where I would edit then publish individual sets of sheets as required. I deleted all sheets [working off of a back-up copy...], and now no more spinning beachball. I have all design layers intact still.

VRAM might very well be an issue, but for now and for me, this is a reasonable fix.

 

Thanks all.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×