Jump to content
  • 4
Christiaan

Please stop mouse zoom 'skidding'

Question

This has been an annoying problem for many years and I've finally got round to posting a wish because I'm working on a particularly big project, so it's very pronounced.

 

When using the mouse to zoom in or out I often find that VW doesn't respond if the cursor is located over objects on the screen.  Move the cursor to a clear space and zooming is far more responsive. Hence 'skidding', as it kind of feels like you're doing a burn out on the mouse wheel or touch zone.

 

Please eliminate this.

Edited by Christiaan

Share this post


Link to post

6 answers to this question

Recommended Posts

  • 0

Yes, that can be terrible hindering in crowded Files.

And it is often hard to find an "empty" space in your Model.

(I had oped there would have come a solution for this over the years - not ?)

I think it has to do with Object Selection/Highlighting/Snapping which seem to

have priority over and stop View Navigation Commands as long as they are

occupied ....

 

I didn't experience that issue in the past again because my projects were

moderate in size again. So no suitable Demo File here to test.

 

But while thinking about it,

have you ever tried to Zoom, while holding the Snapping Pause Key ?

(If that will work at all at the same time ?)

To test if it has only to do with Snapping ...

 

And Maybe one could try if Zooming works better when all Highlight Features

deactivated in VW Prefs ?

Share this post


Link to post
  • 0

I would like to take this opportunity to ask for the following mouse behavior again:

 

1 finger on the mouse = panning

 

2 fingers on the mouse = zooming

  • Like 1

Share this post


Link to post
  • 0
22 hours ago, Kevin McAllister said:

I'm sure its related to selection highlighting still being single core.....


You got it. This limitation will indeed be removed and things will become much snappier. 

Disabling selection highlighting entirely helps, but I can't personally tolerate just the selection handles unless I'm doing a demo and not modeling things. My first version was Vectorworks 12.5 so I got used to the highlighting in 2008 right away and have relied on it ever since.

  • Like 1

Share this post


Link to post
  • 0
1 hour ago, Jim Wilson said:

Disabling selection highlighting entirely helps, but I can't personally tolerate just the selection handles unless I'm doing a demo and not modeling things. My first version was Vectorworks 12.5 so I got used to the highlighting in 2008 right away and have relied on it ever since.

 

I work with pre-selection highlighting disabled and its a much better workflow in high geometry situations. Not sure if its still turned on by default. Ironically you don't really need it anyway since snap highlighting does the same thing. Both of these systems can really bog things down especially on a sheet layer with a lot of camera viewports. There could be some unification of how all this works.

 

VW12.5.2 was the most stable version of VW I remember. VW2008 was not a great experience for me and many others. It upped the system requirements substantially (sort of like the last couple of versions) and many people had trouble with things like pre-selection highlighting and snap highlighting.

 

Kevin

 

Share this post


Link to post
  • 0

tap "H" before mouse zooming, most of the time I will need the hand to pan 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×