Jump to content
Mickey

Undo not working with Lighting Instruments

Recommended Posts

Oh Nemetschek,

Why do we go though this every time there's a new release. You break something that used to work fine.

2019 SP1 Spotlight

Undo is not working correctly with lighting instruments.

I've seen a few different errors so far.

When at the very start of a design I often spread fixtures around looking at different options.

Maybe duplicate array, or duplicate, and move, or click- control - drag and duplicate, or just click to insert.

If I don't like what I see CTRL-Z!

Oh, but now that doesn't work.

Undo either doesn't undo at all, or it leaves a little rectangle where the instrument used to be, but still has all of the instrument information.

I've tried with several different fixture types, and they all have issues.

The rest of undo works fine regarding non lighting instruments.

Sad.

I'll submit a bug as I can recreate this on an existing file, or a new file.

 

 

 

 

  • Like 2

Share this post


Link to post

I'm not seeing this at all, so the issue might be more specific to your files or configuration. Also, undo errors can trickle down to future actions, so try duplicate and undo on a newly opened file.  If that works, the undo bug is with another object.  When you submit the bug, include your user logs and indicate the date and time, including timezone, to the best of your recollection when you first encountered the undo issue.

 

If you experience the undo issue even in newly opened files, you can try creating a new user date folder via Vectorworks settings>User Folder, choosing a folder, and creating a new one via the explorer dialog.

 

Also, you should try updating to 2019SP2, which released last week.

Share this post


Link to post

I have also had this and similar problems with undo Rotation.

 

I have a Truss Structure that is hung on a 25 DEG angle when I rotate the structure it rotates correctly in place. 

Hit undo and only the Lighting fixtures un rotate they revert back correct but the truss is still displayed as rotated but can only select  when you select as if the undo had worked.

 

so you can select the truss as if it had no rotation but it is still displayed rotated. only a revert to saved fixes this issue.

 

Also show 3d only option on truss deletes 2d info from drawing if you unselect show 3d only after you have saved drawing truss is not visible and only insert points are shown.

 

and we are @ SP2 level. 

 

Hours of my life I will never get back 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×