Jump to content
  • 0
lgoodkind

Symbol images in worksheets

Question

Am I the only one who continuously has problems trying to get symbol images to show correctly in worksheets? IS there a trick I'm missing or does it just not work that well?

See below for typical example - I see a 'C' but no linework.  This is a symbol from the VWorks library

 

image.thumb.png.80d52546dc97eaa7799095a60340cfd5.png

Share this post


Link to post

19 answers to this question

Recommended Posts

  • 0

@lgoodkind - have you set the column format correctly?

 

1880499419_ScreenShot2018-12-01at15_52_44.thumb.png.142932673214f5502ad51c9d8ecb0b90.png

 

Playing with the options will maybe provide a better layout for the image you are hoping to show.

 

1306582884_ScreenShot2018-12-01at16_00_59.thumb.png.1dfabb6d5da8edfafeede9b7bb07b373.png

 

 

Share this post


Link to post
  • 0

Thanks for your response.  Yes we've had this problem for years and have tried EVERYTHING under the sun.  No we cannot get the display you show above.  All we get is a letter C - with the same settings you show.

image.thumb.png.e99ba2a124e7e1a2c1cae19d219a6b08.png

Share this post


Link to post
  • 0

Oh - sorry thats not worked. I felt sure it was just the 'quirky at best' image function not displaying correctly and that by experimenting with the settings in cell format you would crack it. Seems its more problematic.

 

You say its all symbols? Maybe others can offer advice if they've experienced similar problems.

 

Happy to take a look at a sample worksheet if you think that may help.

Share this post


Link to post
  • 0

Not what you want to hear @lgoodkind, but Ive tested this again and I can't get it to not work.

 

Surely its just that symbol? Or maybe a group of symbols that you use a lot. (Although I know you said it was a stock VW Library issue)

 

Edit - What version(s) are you guys running?

Edited by Gadzooks

Share this post


Link to post
  • 0

I have issues with symbol images on worksheets as well.  I've even gotten it to work in one file and tried pulling that worksheet into a different file and it doesn't work again in the new file.  My cell formatting is the same as shown above in the previous post.  I have my worksheet set up so the first column shows the image and the second column has the symbol name.  My image doesn't show up at all.

 

Screen Shot 2019-12-13 at 12.26.30 PM.png

Share this post


Link to post
  • 0

Does the database criteria have something specific to the first file - like a layer name?

 

What happens if you set the size to a custom scale and choose something appropriate?

Share this post


Link to post
  • 0

We set up the worksheet in our template file, so every file we work in has the same layers.  I tried formatting the column to show the image at a custom scale.  It changes the size of the cells, but still no image shows up... so that makes it almost seem like it's there but you can't see it?  

 

Additionally, the symbol I'm using is the same between files because they are also in our template.  So that makes it a bit more perplexing that it works in one file and not the other.

Share this post


Link to post
  • 0

Any classes that could be turned off?

 

Feel free to post the file or send it in a PM.  

  • Like 1

Share this post


Link to post
  • 0

2019... we were having the same issues in 2019, but I used to be able to delete and recreate to get it to work, but that's not working now.

Edited by Jessica Maw

Share this post


Link to post
  • 0

Check your classes.  Those symbols are all in the MEP class, which is set to invisible.  The contents of all the symbols I checked was Notes-Sheet.  Make sure that is also visible.  Then recalculate the worksheet.

Share this post


Link to post
  • 0

That worked!  I can't believe I didn't think to check classes.  That's usually the first thing I check when things don't look right, but I guess I didn't think a worksheet would by controlled by classes.  Thanks again.

Share this post


Link to post
  • 0

I wish worksheets could have their own class visibility - like viewports.

 

Good idea for the wish list!

Share this post


Link to post
  • 0

If a worksheet is placed inside vp annotations does it use the vp class visibility settings? If so that would be a good work around for any worksheets using images for classed symbols. 

Edited by Boh

Share this post


Link to post
  • 0

Good question @Boh  I had to think about that.

I just tested it and I think the answer is no.  Image visibility in worksheets follows the current visibility, not the viewport visibility.

 

Even more reason for a class visibility function on images in worksheets.

 

For example, it would be nice to use images of lighting instruments, but be able to control what parts of the label show in the image function.

  • Like 2

Share this post


Link to post
  • 0

I have another question. Is it possible to adjust the image size for each individual cell? It doesn’t seem so. I end up with outlet symbols the size of ceiling fan symbols on the worksheet, even though the fan is much bigger on the floor plan. 

Share this post


Link to post
  • 0

Whatever you do for one image you do for all the images in that database.

 

I always set the scale to the same as the viewport they are next to so they size is the same as in the viewport.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...