Jump to content
  • 0
bjoerka

VW19 - DWG import generates strange result

Question

today i received a small dwg which is totally messed up after the import.

geometry is shifted / ghosted, after editing symbols drawn twice on the screen.

changed several import options, but nothing changes. testes on sp1 - sp1.1 and sp2

the file opens flawless in autocad on mac. generated with ac on win.

see the screenrecording...

 

 

Share this post


Link to post

4 answers to this question

Recommended Posts

  • 0

I have this issue with all DWG imports in VW 2017. The fix for me is to select all, move by points, move all objects from their current position back to their current position. The ghosting then disappears.

 

I know this is a workaround rather than a solution, but if it works it at least means you can use the files.

Share this post


Link to post
  • 0

oh wow. dwg into 2017 was never a problem at all.

also when i import this specific file into 2017 and 2018 it appears to be ok.

 

thanks for the workaround.

another one is to edit the symbol, nudge the geometry with the keyboard right and left and exit the symbol.

after that the ghosting disappears (mostly) too.

 

but i am aware to do this with huge dwg imports...

hopefully things in 2019 will speed up with the upcoming service packs... sp2 is terrible slow...

Share this post


Link to post
  • 0

Hello bjoerka,

 

I believe, that this problem was already for sp3. It is related to the proper regeneration of the drawing - i.e. objects are imported correctly, in their right positions, but due to a missing drawing regeneration graphics does not look as expected. This additional regeneration was not necessary in previous versions, but for VW2019 it has to be done. This problem appears only for some files, which is the reason to not been found and fixed earlier.

 

For now I could propose two workarounds:

1) Import the DWG in Vectorworks and immediately after the import has finished, without switching to another layer or zooming, save the document, close it and then open it again - everything should be regenerated correctly.  

2) Import the DWG using the Location import option "Align with Internal Origin". Graphics will be drawn correctly. If you need the drawing to be centered, then use the menu command Tools-->User Origin-->Center Drawing on Internal Origin. (Note: Importing with Location option "Center first import, align..." (for a first import) or "Center on Internal Origin" are equivalent to importing with Location option "Align with Internal Origin" PLUS using the menu command Tools-->User Origin-->Center Drawing on Internal Origin.)

 

If you still have a problem using the workarounds, please, send the DWG file directly to me.

 

Best Regards,

Nina

Share this post


Link to post
  • 0

Hi Nina,

 

that seems to work 😉

I even didn´t try to save - close and reopen that file.

thanks.

best,

 

bjoern

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×