Jump to content
Kerschbaumer

VW 2019 Publishing PDF problem - fonts garbled

Recommended Posts

When I publish a pdf set of drawings then print them out on my printer all of the text is garbled.  Am running VW 2019 with latest up to date service pack and my HP 7740 print driver is is also up to date, I am on a new macbook pro running High Sierra 10.13.6.  When I use the 'file' 'export' 'export to PDF' command and check the 'rasterize text' option the text then prints just fine.  Using the 'Publish' sommand it does not give me that option and text always garbles.  Attached are pics.  The first is of the on-screen pdf as generated by VW.  The next is the garbled text print out using the 'Publish' command and the third is using PDF Export command.

 

I recently switched from VW2013 and never had this problem.  I opened up some old PDFs that were genereated from VW2013 and the problem does not exist.  In v2013 there  was no 'Publish' option, we had to use 'export PDF Batch'.

 

Thanks in advance

IMG_6766.jpg

IMG_6768.jpg

IMG_6767.jpg

Edited by Kerschbaumer

Share this post


Link to post

The image sizes of the screen caps you linked are very small (at least for me), but similar issues with PDFs with garbled text have been reported before. (I thought it had been fixed as of Vw2019, but perhaps not).

 

Maybe one of these threads below might help you find a solution other than having to ‘rasterize text’:

https://forum.vectorworks.net/index.php?/topic/44624-pdfs-printing-in-gibberish/

https://forum.vectorworks.net/index.php?/topic/51085-font-mapping-when-exporting-fonts-on-pdf-become-pixelated/

 

And a KB article on how to validate fonts on macOS:

 

Edited by rDesign

Share this post


Link to post

Thanks rDesign

Have read through and tried all suggestions you posted.  I use Arial font for everything.  I did print from Preview and it worked fine.  I also did the font validation and there was a yellow warning for it which I corrected by resetting default fonts and now all green light.  Interesting when I change the font to Courier it works fine.  When I print from Adobe Reader and a very old version of Acrobat Pro they both are garbled.  Only thing I can think of is that there something that VW2019 does when it generates the pdf that Adobe products dont like in the font......Have pent half the day and half my ink trying to sort this out....

 

Share this post


Link to post

Seriously scratching my head here and not having any luck fixing problem.  Courier font works fine, Arial does not.  Not about to change fonts after 20 years... attached a pic of the print out using both fonts.

IMG_6773.jpg

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×