Jump to content
  • 0
Seth Thomas

Rendering issues

Question

On 10/9/2018 at 1:59 PM, Patrick Fritsch said:

VW is still not remembering the last view of a saved file, when you open a file it's at some random view.?

This is happening to me as well, but I'm still on High Sierra 10.13.3, so it's not strictly a Mojave thing. As @Tom Klaber mentioned, it's not technically random, but it is definitely wrong, and very disconcerting.

 

I know this thread is about Mojave, so I don't want to go to deep here, but another issue I've experienced is: If I render a camera viewport on a sheet layer it will render correctly the first time, but when I switch to a different sheet, then return to the sheet just rendered, it presents as a fully white viewport. Then, when I re-render the viewport it will render about 95% and leave black bars for the final few blocks. The percentage & location of the black bars changes with each subsequent render. Then, when I leave the sheet and return, it presents as white again. It's not just a screen refresh thing either because it exports this way also. It also flashes while rendering, which almost gives me a siezure.

 

I've had 2019 for less than 24 hours and it's already a huge disappointment, but that was to be expected. For every one thing they fix, they break something else. These releases are barely ready for beta, let alone an official release. And even after SP2 of any given release, many issues are never even addressed. I know of no other major software with problems of this magnitude. It's very frustrating.

Edited by Seth Thomas
  • Like 1

Share this post


Link to post

11 answers to this question

Recommended Posts

  • 0

Just installed SP1.1 and can confirm that it did not fix the rendering issue I mentioned above, and in fact it is now worse. It now goes straight to a white viewport when rendering is complete and never gives a finished view. Very dissapointing since @JuanP stated that:

 

Quote

 

We have identified additional fixes that we are including in the SP1 of Vectorworks 2019.  

 

General Fixes in SP1.1:

 

This service pack includes fixes and improvements in the following areas:

Sheet layers viewports not showing final rendering 

Rendering differences between Vectorworks 2018 and 2019

Renderworks sheet layer viewports occasionally fail to update

Wall components displaying incorrectly in section viewports

Cut objects attributes in design layer section viewports are sometimes incorrect

 

 

Three of the five items listed above relate to rendering, and yet RENDERING STILL DOES NOT WORK. I can work around annoying glitches, but if I can't render than the whole program is useless.

Share this post


Link to post
  • 0
2 hours ago, Seth Thomas said:

If I render a camera viewport on a sheet layer it will render correctly the first time, but when I switch to a different sheet, then return to the sheet just rendered, it presents as a fully white viewport. Then, when I re-render the viewport it will render about 95% and leave black bars for the final few blocks. The percentage & location of the black bars changes with each subsequent render.

 

I am unable to replicate this at all, the same problems continue after restarting the application completely? Same issue happens in multiple files? Could you also attach a screenshot of the odd black bars you're seeing please?

Share this post


Link to post
  • 0

I've done this on multiple files with multiple machines. I've restarted the application and rebooted the computers. I've also tried re-converting files from 2018 to see if the file somehow became corrupted during conversion. No luck. I have a Mac Pro (Late 2013), 3.5 GHz 6-Core Intel Xenon E5, w/ 16 GB RAM running macOS High Sierra 10.13.3 and a MacBook Pro (Retina, 15-inch, Mid 2014), 2.8 GHz Intel Core i7 w/ 16 GB RAM running macOS High Sierra 10.13.2

 

I can't send a screenshot because since the SP1.1 update it never even gets to that point. Since then, the viewport goes completely white when the rendering is complete (I also have to be very careful about sending anything because I work for a very litigious company with a lot of trade secrets, but I will provide as much info as I can). To describe it though: As I'm sure you know, a camera rendering starts in the center of a viewport and renders out squares in a bit of a spiral pattern until it reaches completion at the edges. In my case the final few squares at the edges would remain black, to differing degrees for different attempts. I'll also note that, unlike 2018, my 2019 makes the entire viewport black before the image begins to render, then flashes the entire viewport white occasionally as the render progresses.

 

Share this post


Link to post
  • 0

Send me one of those files in a direct message please, I can take a closer look.

Share this post


Link to post
  • 0

Unfortunately, I do not have permission to send any files. Everything I work on is confidential and I would certainly be fired if I let information leak, even for something like this. I've asked before. Sorry, I know your trying to help, and I appreciate it.

 

I may try an uninstall and fresh re-install.

Edited by Seth Thomas

Share this post


Link to post
  • 0

OK Jim, so I have a clue. I just uninstalled and re-installed 2019 after which rendering worked as it should. The same files that were displaying the symptoms I described above rendered properly. This worked multiple times on both computers.

 

BUT, there is one thing that I did differently. The first time I installed the software I used the Migration Manager to move all my settings across. That is when I had the rendering problems. This time I skipped migrating my settings and everything rendered as it should. It still flashed and made me think it wasn't going to work, but in the end the rendering was persistent. Then I ran the Migration Manager on the newly installed VW and the rendering problem returned. I can't imaging what the specific problem could be, but it has something to do with the Migration Manager.

 

I also tried rendering after installing 2019, but before installing SP1.1. The rendering was OK, but the black squares were there. I discovered that refreshing the sheet by pressing command-4 fixed the black squares, but it also looks like SP1.1 may have fixed this also since I do not see the squares after that update.

 

Another oddity: I'm pretty sure the first time I installed and migrated my settings, VW did not ask to update resource libraries. The second & third times, when I did not migrate, it did ask to update resources. Could this be related? Are the resource library settings stored in personal settings?

 

While I'm super annoyed that I can't translate my custom settings over (because I customize practically everything), I'm happy that I've figured out how to make 2019 work. Hopefully that's a clue you can use to figure out what's going on, and pass along to anyone else who has the same issue.

 

Thanks for your help.

Share this post


Link to post
  • 0

It's the default compression setting. It works in PNG mode, but creates a solid white render in JPG mode. I use JPG because they are usually smaller file sizes and we use A LOT of graphics, so I do what I can to keep the overall file size small. When I migrated my settings the first time, it brought with it the JPG setting. Reinstalling initially fixed the problem, but when I went through and manually setup my preferences, it came back. I deduced that it must be one of the settings, so I decided to go through and test them all one-by-one. Fortunately my first inclination was the correct one, and it didn't take long to figure out. Now I can toggle the problem on and off by changing the default compression setting. Glad I know now, but this needs to be fixed. I don't really understand why PNG is an option anyway since it is intended for the web, not for print. If I could get a proper CMYK output from VW I'm sure my prints would look much more like the screen, but I digress.

  • Like 2

Share this post


Link to post
  • 0

image.thumb.png.c0ef6ce14963c304ae94394f352e7b6d.png

 

Hi @Seth Thomas

 

I had this. It's hard to pinpoint what solved it but deffo SP1.1 has resolved a number of rendering problems for me. Also the above instruction which @Jim Wilson will be aware of which might save an entire reload?. Hope that helps D

 

 

 

 

Share this post


Link to post
  • 0
On 11/8/2018 at 9:59 AM, Seth Thomas said:

It's the default compression setting.

 

Firstly, @Seth Thomas: That was some fantastic sleuthing. I take my hat off to you sir. Really, well done. 

 

I've just finished assisting two of our users with this issue. Changing the default compression worked for 'User 1' but 'User 2's experience was a bit different, - for whom:

  • (I avoided running the updater at first (like I did for User 1) so as to determine if updating was a factor)
  • her compression was already on PNG
  • changing it to JPEG then back to PNG didn't work
  • Resetting Vectorworks Preferences didn't work
  • I was going to prescribe updating next but they did a complete uninstall/reinstall before I could and this did work - so it looks like using at least SP1.1 and using PNG as the default compression are both required for the Default Compression setting to have the desired effect. 

Share this post


Link to post
  • 0

Thanks @Jeremy Best. VW offers many great mysteries to test my troubleshooting skills, though I would much prefer if it just worked.

 

That's another interesting case. There are many moving parts that can have issues. Sometimes we just have to start from scratch and let go of the desire to know why.

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×