Jump to content
Oliver Hauser

Title Block Manager crashes VW2019 Sp1

Recommended Posts

Hello Oliver,

 

I have managed to open the TBManager and Refresh the Plot Date successfully in the attached file.

Could you send me a crash report or a screen recording showing the crash?

 

Best Regards,

Nikolay Zhelyazkov

Share this post


Link to post

Thanks for the quick reply Nikolay.

 

Below is the report. Will send a recording soon.

 

Description
Faulting Application Path: C:\Program Files\Vectorworks 2019\Vectorworks2019.exe

Problem signature
Problem Event Name: APPCRASH
Application Name: Vectorworks2019.exe
Application Version: 24.0.1.0
Application Timestamp: 5bb74e7c
Fault Module Name: Vectorworks2019.exe
Fault Module Version: 24.0.1.0
Fault Module Timestamp: 5bb74e7c
Exception Code: c000041d
Exception Offset: 000000000232a085
OS Version: 10.0.17134.2.0.0.768.100
Locale ID: 7177
Additional Information 1: 271a
Additional Information 2: 271a08f73f70cd6626d3305e440f8c09
Additional Information 3: 5539
Additional Information 4: 55398d777c3411aca77c6fd0a98838c9

Extra information about the problem
Bucket ID: 7374a24ceb5bbd5300ac791e3712250b (1201468371280995595)

Share this post


Link to post

You are working on Windows, right?

If so, open your VW user folder at "<user name>\AppData\Roaming\Nemetschek\Vectorworks\2019\" and look for a .dmp file that was created when your VW crashed when opening TBManager.

Share this post


Link to post

Oliver,

 

Thanks, this helps a lot, but I am still not able to reproduce the crash.

Is it crashing always for you or only sometimes? Could you tell me what exactly are you doing before the crash occurs? It would be best if you give me the steps from the very opening of the file until the crash.

 

Best Regards,

Nikolay Zhelyazkov

Share this post


Link to post

I had the same problem with the Instrument Summary. I had to Save the file in VW 2018. Insert the Instrument Summery and then re-Open in 2019.

Share this post


Link to post

@Oliver Hauser

 

I found out where the crash comes from, but I am still not able to reproduce it. And without reproducing it, if I make a 'fix', I cannot be sure if it will actually fix the problem or not.

That is why I need more information on that how to reproduce the issue, what was done before the crash.

Share this post


Link to post

Thank you for the provided video. How did you duplicate an existing Title Block? Drag & Drop from resource manager? Or copy paste?

Also, how did you make it your own? Convert to unstyled?

 

Thanks again for the feedback! 🙂

Share this post


Link to post

Right clicked on an existing title block template (specifically the CITT title block) in the resource browser and duplicated it in my drawing. I edited the style via the object info pallet and then assigned the duplicate to my title block border.

Share this post


Link to post

I am still not able to reproduce this crash... I suppose we are doing different steps. Could you try to reproduce it from the begining and record the steps you are doing, so that I could repeat exactly the same steps too?

Share this post


Link to post

I'm still constantly experiencing this crash. I have attached another drawing that is doing the exact same thing. The drawing is untouched since the crash.

 

I would suggest opening the drawing, double-clicking on the title block, select Title block manager then click ok. This should reproduce the crash.

229.HLD Light Plot_Nutcracker 2018.vwx

Share this post


Link to post

Thanks for the user folder, but still nothing here.

Could you please make a screen recording of the crash from the very opening of the last attached file until the closing of Vectorworks, because of the crash?

Share this post


Link to post

@Oliver Hauser

 

First of all, thanks for the detailed feedback and for not giving up on this! 🙂

I was finally able to reproduce this issue. In the end, this is not the crash from the initial crash report that you have sent me.

What is happening here, is that the Title Block Manager is trying to load the folder that is located at "..\..\..\..\" relatively from the active file. There seems to be big folder hierarchy that is causing VW to freeze, why traversing it. There is a fix about that in SP-2.

However, as a workaround, you could place your file in 4-5 empty folders each next placed in the previous like "Folder1/Folder2/Folder3/Folder4/Folder5/<file here>". Let me know if the workaround fixes the problem.

 

Best Regards,

Nikolay Zhelyazkov

  • Like 1

Share this post


Link to post

Thanks so much for all your effort Nikolay.

 

I suppose this is the only way we can make VW better in the long run. Will let you know how workaround pans out.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×