Jump to content
Daniel B. Chapman

Decals not appearing in OpenGL

Recommended Posts

I'm trying to render some paints over a glowing texture (basically simulating paint on a frosted surface that has back-light on it) and it is working in Renderworks. However, when I view the same objects in OpenGL I end up with a blank surface per my second image. 

 

Is there something I'm doing wrong? Decals seem like the right approach for this workflow and I would love to be able to set them in OpenGL rather than swapping to Fast Renderworks to set position as it is, for obvious reasons, a faster workflow.

 

Any help would be appreciated.

image.thumb.png.4dacc3c6ee73634789e381cac885e086.png

image.png

Share this post


Link to post

Decal Textures will not display in OpenGL. Our OpenGL implementation is only capable of displaying one texture per surface. This is something we will likely improve in the future with the inevitable replacement of OpenGL tech, but this would be a version or more away.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...