Jump to content

Shutter changes not showing in renders


Recommended Posts

I just started using VW 2019 and am wondering if anybody else is having issues with rendering lights with shutters in place.

I have a light pointed at a 3d solid and it shows up fine in Open GL, Fast or Final render.

If I put a shutter cut in place then I can see it in the wireframe view but it doesn't always show up when I switch it to the other modes... sometimes it does.

Sometimes I will change a cut and it will show but then if I edit the fixture and adjust that same cut, when I come out, the change doesn't render.


I've tried this in the drawing I'm working on with 50+ fixtures with shutters and also with a test file of just one light and a surface.


Is there anything I could be missing that might make these changes visible in some cases but not in other?



Dave H.


Link to comment

To see shutters in OpenGL you need to turn on shadows on OpenGL. This has the knock-on of making the texture that the 3D portion of the light is filled with block the beam, so no light will emit. The workaround is to temporarily remove the fill from the class that holds your 3D portion. (I do this all the time and have all my 3D portions assigned to a particular class). Then you will see the shutters. The other thing to remember is OpenGL will only be able to show 8 light sources at a time, so will only show the last 8 of the 50 lighting devices you added to your drawing. After you've done that, then shutters SHOULD show up fine.


Shutters and all your lights should show up in any Renderworks mode. (Fast,Custom etc.)


BTW. Are you using viewports or are you rendering from the design layer?

Link to comment

Hi Mark.

I am rendering from the design layer.

If I switch on shadows, the light just flashes and then blacks out -- and it doesn't show the correct shutter cuts.

If I switch off shadows then the light stays on (no cuts shown).

Not sure which class is the 3d portion of the light... how would I find out?


And, I'm only doing one light at a time.


Thanks for the help.


Dave H.

Link to comment

Here's something I just discovered. If this light is on in open GL and I rotate the view, I see the attached image.

As soon as I left go of the mouse button, it disappears.

It looks like the beam is being almost completely blocked but there is nothing in front of it.


(the deformed beam is because it's shining on two flats at different places)











Link to comment


17 minutes ago, acdeslx said:

If I switch on shadows, the light just flashes and then blacks out -- and it doesn't show the correct shutter cuts.


That is because the fill of the body of the light blocks the beam. This is because the light emitter is placed at the Locus Point of the Instrument symbol which essentially is where the yoke pivots.


To see shutters you need to remove the fill from the body of the symbol. To do that, you need to find out what class attributes the body is made with.

  • Go the the Instrument symbol  (Right click on the instrument and select "Locate Symbol in Resource Manager")
  • Right click on the symbol and select Edit 3D
  • Select the 3D portion
  • In the OIP it will tell you what class the 3D portion is assigned to.
  • Once you have ascertained the class, go to the Organisation Dialogue and change the fill attribute of the ascertained class to None. (Make sure Use at Creation is checked).
  • You need to refresh the instruments once you have done this.


Once you get the hang of it, its really very quick and easy and takes just a few seconds.


The above rigmarole is because Instrument textures are set to NOT CAST SHADOWS so that light will go straight through when rendered in Renderworks. However, OpenGL does not understand this setting so the Solid Fill of the light blocks the emitter - hence your problem and why it is imperative to remove the fill from the device for Open GL in order to see shadows from Lighting Devices.


The shutters are created by placing a mask in front of the emitter which needs to cast a shutter-shaped shadow!


I don't exactly know why you are getting that shape of shadow in your image, what instrument are you using?


Post or PM the file and I'll take a look if you like....

Link to comment

The suggestions worked to solve the Open GL issue AND it shows the changes right away -- thank you.


However, when I flip to the Renderworks engine, the beam is still showing full size.

How do I solve that part?


Of course, after that I have to see how to get rid of the focus points which are already placed in an invisible class -- arrgh







Edited by acdeslx
added pic
Link to comment

I assume that your focus points class is turned off? If that is the case, then you may have run into a bug with Renderworks where every now and again it fails to completely wipe the "Cache" of the previous render. This generally happens if you are using the same settings as before. It also seems to happen more often (for me anyway) when you are using Fast Renderworks. Try using Custom Renderworks or create a new Renderworks Style. That should persuade the renderer to restart the render process from scratch.


Hopefully that will solve your focus point visibility issues as well as allow you to see the effects of your shutter cuts.

Link to comment

Thanks for the message.


I took a look at the file. I am afraid that I had no problem rendering the shutters. I have a feeling you are still suffering this caching problem. Try going to Custom Renderworks and set all the settings to low. Then go to the resource manager and create a New Renderworks style. The style will be based on the Custom Renderworks style you just made. Then Duplicate it.


Whenever you want to render a view, double-click this new Renderworks style instead of using the presets. I have found that I can mitigate the caching problem if I alternate between the two identical Renderworks styles. 


As far as I am aware, the preset styles are more "legacy" items and whilst they're helpful from time to time, you will get much better control over your renders if you use Custom Renderworks and tweak the styles based on what it is you are rendering and the quality you need.


Below are a couple of screen shots showing the shutters in place.....


(btw, I turned off the wireframe beams o the off-chance that that might be causing the problem......)


Screen Shot 2018-09-26 at 19.43.32.png

Screen Shot 2018-09-26 at 19.44.32.png

Edited by markdd
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...