Jump to content
  • 0
Samuel Derenboim

VW 2019 PDF Ref's Dissappear on conversion

Question

For some reason upon converting a vw 2018 file to vw 2019, all pdf references in the drawing disappeared but remained in the references pallete. 

Two questions :

1. Is this a bug?

2. is there a way to get the pdf references out again into the drawing from the reference list? or do I have to drag them into the drawing once more?

 

Thanks in advance!

  • Like 1

Share this post


Link to post

12 answers to this question

Recommended Posts

  • 0

Hi Everyone, Just to add, after re-adding the pdf references, and formatting them, they disappear once more even after saving with the new VW 2019. So heads up, seems like this is a bug.

Share this post


Link to post
  • 0

@assemblyarchitecture Unfortunately It is a bug. But my workaround was to import the pdf's into the document and not reference them. It seems to hold the pdf file in the same format, only without auto update. I'm sure it will be fixed soon.

Share this post


Link to post
  • 0

2019 Service Pack 1, Imported PDF's now show up as grey rectangle with cross thru.

 

These are not referenced files, actual imported PDFs, directly to a Sheet Layer. 

 

See comparison to same Sheet Layer in 2018sp3  vs. 2019sp1

 

Is this experienced by others, or something about my settings ?

Screenshot 2018-10-11 08.32.52.png

Share this post


Link to post
  • 0

Hi @Samuel Derenboim, @assemblyarchitecture & @gmm18

 

I provide Tech Support for users in the New Zealand market and have had one report of this but I have not been able reproduce it nor has the user [been able to] find and supply the original PDF yet. Perhaps if you can provide me the necessary files to test and verify these issues I can help forward the bug submission, verification and resolution process. 

 

I've had one firm report multiple files with referenced PDFs not displaying in Vectorworks 2017, but not all files are affected.

 

If you're experiencing issues with all PDFs, then: 

As not all users are experiencing this, then it's likely something particular to your circumstances is responsible. Some of the variables mentioned below might still be of use to you, but it might be warranted to try: 

 

If you're experiencing issues with some PDFs but not all, then: 

 

See if the problem ones are a different file version than the ones that do work. Please note these as-you-go. To determine PDF Version: 

  • On Mac: Open PDF in Preview and 'Get Info' 
  • On Win: Open in Adobe Acrobat Reader DC and go: File > Properties... 

Other variables to consider: 

  • Are the PDF files kept on a server? - Is the server functioning normally? 
  • Are Read/Write permissions/privileges blocking access for Vectorworks? 
  • Does the file or any parent folder (directory) have really long names or unusual characters in them? 
  • Is the reference file path: 
    • Relative to the position of the document, or 
    • Absolute (specifically defined). 

 

May I suggest you try to identify the offending condition using the following tests/processes: 

 

Perform an acid test: 

  1. File > New > 'Create blank document' 
  2. File > Import PDF > choose PDF and check 'Reference' if that's what was used before. Otherwise leave it unchecked to import it into your document. 
    • If the issue does not occur, then the issue is likely conditional of your original file. Try the following remedies with your file: 
      • Check for 'far out objects' and move/delete any you find. See the following article: If this isn't relevant or removing 'far out objects' doesn't work, then... 
      • Export your document to a prior Vectorworks version (File > Export > Vectorworks 20XX) then reopen it in the version you're experiencing this issue with. 
    • If the issue persists and the PDF is on a server:
      • Put the PDF on your local hard drive and try the above acid test again. 
    • If the issues occurs again, then it's likely a Vectorworks bug, regardless of whether the PDF version is a factor, but it will be important to determine what versions (if any) are affected. 

Please let me know what you encounter and I'll see how I can progress this matter. 

Edited by Jeremy Best
Grammer and elaboration

Share this post


Link to post
  • 0

I have the same issue. PDF import works perfectly in both Sheet & Design Layers in VW2018 but only imports as a greyed out box with an "X" in VW2019. I have reset preferences and tried all of the previous suggestions but nothing works to resolve it. VW2018 files opened in 2019 import PDFs as grey boxes too. Back to 2018 for now as I use this feature quite a bit.

 

I can provide test files on request.

Share this post


Link to post
  • 0
5 hours ago, JCArchitects said:

I can provide test files on request.

Thanks @JCArchitects! I'll PM you my Tech Support INBOX link to obtain your PDF files. 

Share this post


Link to post
  • 0

Hi everyone, ( @Samuel Derenboim, @assemblyarchitecture, @gmm18 and @JCArchitects) I have an interim solution. 

 

Not all PDFs are affected by this issue, so I suspect the way they are formatted by the software that generated them is the outside-Vectorworks factor. I have confirmed this issue does not correlate with a PDF's file version. As all PDFs should be compatible with Vectorworks and as it occurs in VW2019 but didn't in VW2018 I'll be submitting a bug report today. On the bright side, here is an interim solution: 

 

PDFs exhibiting this issue should all work with VW2019 if you:

  1. Open the PDF in a PDF viewer or editor (say Preview on Mac or Adobe Acrobat Reader DC on either Mac or Windows), then 
  2. Export the PDF as it is / with no changes. (You may want to keep a multi-page PDF entire to maintain context in your records). 
  3. Then import into VW2019. 

If the above does not resolve it for you, try a different PDF viewer/editor and please let me know what you encounter. 

 

Cheers, 

Jeremy 

Edited by Jeremy Best

Share this post


Link to post
  • 0

Hi Jeremy,

 

Sorry that didn't work for me. Tried it on a few PDFs but no luck. Used both Adobe Acrobat Reader DC & Soda PDF to "Save As" the original PDF.

 

Jim

Share this post


Link to post
  • 0
14 hours ago, JCArchitects said:

Sorry that didn't work for me. Tried it on a few PDFs but no luck. Used both Adobe Acrobat Reader DC & Soda PDF to "Save As" the original PDF.

Hi Jim, 

 

I don't expect 'Save As' to have the desired effect because this just saves the file as-it-is with a different name. You must choose 'Export,' as I did (in Apple's native Preview app) which recreates the content instead.

 

I've since appreciated that Adobe's Acrobat Reader doesn't offer an Export-as-PDF facility so you'll need to find an application that does. Or for users on Windows that have a 'print to PDF' function in your Print dialogue that should work too. (Note: For Mac users reading this, you all have Preview and native 'print-to-PDF' included with your Mac). 

 

In the meantime, Jim I'll message you back your PDF that I exported. It works for me on Mac and Windows so please test it and report back here what result you get, - because if it doesn't work for you then something particular is going on that should be diagnosed. 

 

 

Cheers, 

Jeremy 

Share this post


Link to post
  • 0

Hi Jeremy,

 

I used the "Print to PDF" function as above and it definitely works. Thanks for your help on this.

 

Jim

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×