Jump to content
gfebres@gfarch.ca

VW 2019 some Shortcuts not working

Recommended Posts

I recently upgraded to VW 2019, and some basic shortcuts do not work, particularly the ones to select drawing tools, like a line. If I use the shortcut (2), it changes the view to an elevation view. I verified the workspace and the shortcuts are as they should be, but when used VW goes to different views instead of selecting the tool I want. Please help

Share this post


Link to post

the number pad will change views, to use the number shortcuts you need to use the number keys above the letter keys.

Share this post


Link to post

Hi

Can I assume you have an extended keyboard with a number pad? If so, click on the cog icon to the top right of the drawing area and choose Allow numeric keypad entry for Instant Data Bar Activation. This should stop the view changes.

image.png

Share this post


Link to post

Another thought....

 

2 is line and Cmd+2 (or Ctrl+2) is front. I wonder if one of the keys on your keyboard is being pressed down inadvertently?

 

I once had a similar issue, which was fixed when I realized my external keyboard was underneath some crap on my desk and keys were being pushed, haha.

Share this post


Link to post

I had a similar problem with text (1) and call out (option 1) but this was only in one workspace

advice from OzCad (if you edit the workspace and remove then add back these shortcuts, it will work again. Sorry for the inconvenience.)

  • Like 1

Share this post


Link to post

Tested every thing suggested:

As  Rob indicated, using the number keys above the letters instead of the keypad works, but I normally used the key pad for short cuts in VW 2018.

Just tested shortcuts running VW 2018 and they all work, using the keypad, even if "do not allow keypad entry for instant data bar activation" is selected.

 

Tried selecting  "allow keypad entry for instant data bar activation" as Tamsin indicated, but it made no difference VW 2019, shortcuts do not work from keypad, just changes views.

 

Also tested in VW 2019 editing the workspace, setting the "/" (the one on the keypad)  to select the line tool and it works, even if the data bar and edit group options has "do not allow numeric keypad entry..." selected or unselected.

Share this post


Link to post

I have problems

(at least in Mojave)

that Double "X" doesn't deselect anymore.

Share this post


Link to post

Thanks Mar Schrammeyer, removing the current shortcut character, exiting, going in again and replacing the character with the original worked, a bit of work, doing it for each one that did not work, but solved the problem.

  • Like 1

Share this post


Link to post

Hello gfebres,

 

Thank you for your posts and updates. We would like to fix this issue in future releases. I am wondering whether you migrated your 2018 workspace file or edited your 2019 workspace file before the shortcut issue. If you did use Migration Manager, I am wondering if you can send your 2018 workspace file to me so I can investigate.

 

Thanks,

Payne Chang (pchang@vectorworks.net)

Vectorworks Software Engineer

Share this post


Link to post

There was a problem during the migration, it could not migrate my workspace, it indicated that. So I did not start VW 2019 with my work space. The problem started with the workspace that came with VW 2019. I created a new workspace and modified it while trying to fix the issue.

Share this post


Link to post

Thanks a lot for providing your workspace file. I will investigate the issue and make improvements in future releases.

Share this post


Link to post

Having same issue with 2019. New to VW. Began tutorials for 2018, numeric keypad worked A-OK. Upgraded to 2019 last week, no worky.

Share this post


Link to post

After latest upgrade the boomerang mode doesn't stay active by only staying on for a split second (and I'm not even opening ANY file), both on my Macbook Air keyboard and the Apple Keyboard (no extra numeric pad, the short version). It wasn't like this before the VW upgrade about one month ago, and I'm using iOS Mojave 10.14.5 (latest one too). 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×