Jump to content
  • 3

v2019 Section viewport rogue geometry bug is back


Will
Message added by PVA - Jim

This issue should be corrected in Vectorworks 2019 SP1. 

Question

Anyone else seeing stuff like this in vw 2019?

Top is correct drawing from vw 2018 sp4 (it's a work in progress drawing)

Project 1 Screen Shot v2018 sp4 section OK.png

This is what vw 2019 draws....

Project 1 Screen Shot v2019 section failing.png

Again this is correct:

Project 2 Screen Shot v2018 section OK.png

This is the exact same viewport in vw 2019. ???????

Project 2 Screen Shot v2019 section failing.png

 

Interestingly this is the same distortion that used to happen when vw2018 was first released.

Edited by Will
Added text describing the problem
  • Like 1
Link to comment

16 answers to this question

Recommended Posts

  • 0

Unfortunately it has occurred with both the 3D projects I have tried so far. The second one I tried was a clean project started in vw 2018. But obviously some wall styles and things like that are from libraries that have been updated.

 

Its a shame as I really like the snappiness of 2019, the new zoom speed is fantastic.

 

If I had to guess as to what has happened, they probably started work on improving the graphics module, which must have been a pretty major project that has taken a while, and they have forked the codebase before this was fixed in vw 2018 (I think is was maybe sp3) and now the bug is back. Hopefully if that is the case they can port the fix over pretty easily.

Edited by Will
Grammar. Also to say really enjoying the speed of 2019.
Link to comment
  • 0
  • Vectorworks, Inc Employee
19 hours ago, Will said:

Anyone else seeing stuff like this in vw 2019?

Top is correct drawing from vw 2018 sp4 (it's a work in progress drawing)

This is what vw 2019 draws....

 

Hi Will, We are aware of issues like this and are working on them.

Would it be possible to send m you file privately for testing?

 

Thanks,

Matt

  • Like 1
Link to comment
  • 0
1 hour ago, Matt Panzer said:

 

Hi Will, We are aware of issues like this and are working on them.

Would it be possible to send m you file privately for testing?

 

Thanks,

Matt

Yes no problem. By the way, I have already uploaded these two test files through bug submit yesterday.

  • Like 1
Link to comment
  • 0
On 9/16/2018 at 1:44 PM, Will said:

Anyone else seeing stuff like this in vw 2019?

 

I'm seeing stuff that should not be showing. Toilets, sinks, fixtures... classes are off but they are showing in the sections (if the section line touches it, it will show). opened the document in 2018 and it looks as it's supposed to be. Guess I'll go back to 18 when publishing time arrives. BTW I'm noticing faster workflow in 3d, faster panning, zooming, etc.

Edited by RafaelPernia
Link to comment
  • 0

Hidden Line rendering in the viewports seems to be the only thing working for me, Open GL was working then it stopped.  The background rendering was the only thing that was appearing.  I also will stay away from 2019 and suggest everyone also do the same until these god awful issues are fixed.

 

P.S. If you try to call tech support, you will end up on hold for a while.  My opinion is that unless your issue is dire just bear with the bug backlog and stick with the previous version that works for you.  Just what I think is a wise opinion.

Link to comment
  • 0
  • Vectorworks, Inc Employee
26 minutes ago, Kingstone said:

Hidden Line rendering in the viewports seems to be the only thing working for me, Open GL was working then it stopped.  The background rendering was the only thing that was appearing.  I also will stay away from 2019 and suggest everyone also do the same until these god awful issues are fixed.

 

P.S. If you try to call tech support, you will end up on hold for a while.  My opinion is that unless your issue is dire just bear with the bug backlog and stick with the previous version that works for you.  Just what I think is a wise opinion.

To confirm, this was the same after SP1, or only before, or both?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...