Jump to content
  • 1

VW 2019 Render not stopping



Hello; excitedly installed VW 2019, opened a current model small model (4 trusses, twenty four spotlight fixtures turned on, sixteen with fog) and hit render. After an hour and change; I decided to stop the render process and the two choices I am aware of have failed to stop the render.


Hitting escape = no joy


Hitting Cmd + . (period) = no joy either.


Also, VW 2019 shows "Stopping Render" in the message area, yet does not stop…


Thoughts? TiA


Screen Shot 2018-09-13 at 10.44.55 AM.png

Edited by mjm
wrong image for upload
Link to comment

16 answers to this question

Recommended Posts

  • 0
21 minutes ago, Taproot said:

Humorously fact and fiction aren't that far apart:  I actually programmed one of my mouse buttons to simulate hitting escape multiple times ... it has extended the life of my keyboard AND it deselects the text tool without driving me crazy!

Great solution. As I'm trackpad / keypad only, I'd have to make a keystroke or similar…

Link to comment
  • 0
18 minutes ago, Jim Wilson said:

@mjm did you happen to see what phase the rendering was in at the bottom right when you first attempted to cancel?

(Side note: there won't be instant cancelling until we can process geometry multithreaded, but then we will basically inherit that functionality automatically.)

Uh, yes? Maybe? All other phases had completed and this was the longest, slowest portion; could it have been "interactive render"?

Link to comment
  • 0
2 hours ago, LinetteOrigin said:

I am also having this problem with 2019. Pressing esc-esc or cmd + period is having no effect. This is during the "rendering" phase where the little teapot is visible in the bottom right corner. The same phase where cancelling the rendering IS possible in previous versions.

Just ran into this yesterday.

Link to comment
  • 0
On 9/14/2018 at 2:13 PM, Jim Wilson said:

Well, in poking harder at this I think I found the problem. The geometry we are generating inside seating sections is incredibly inefficient. The stock chair symbol, when ungrouped and decomposed, is over 450 vertices. When I manually edit the symbol and add three simple rectangles for the backrest and arms, and a rounded rectangle for the seat, the speed is right back to where it should be. He's out today, but I'll meet with the spotlight features manager to discuss this on Monday.

EDIT: Also split this out into its own thread for easier tracking


On 12/14/2018 at 9:10 AM, mjm said:

Just ran into this yesterday.

And again today. After waiting 36 minutes for the render to complete I decided to eff it and quit the app (VW 2019), consequences be damned. Clicked Vectorworks menu, chose Quit and voila! I was instantly kicked to the 'Quit VW, you want to Don't Save-Cancel-Save' dialog pane. Choose cancel!!! That kills the render and allows the continuation of work.

See the brief attached movie, in which you cannot see me hit CMD+period or ESC repeatedly, till I then choose the Quit VW menu item.

Link to comment
  • 0
On 12/18/2018 at 11:59 AM, mjm said:

chose Quit and voila! I was instantly kicked to the 'Quit VW, you want to Don't Save-Cancel-Save' dialog pane. Choose cancel!!! That kills the render and allows the continuation of work.


I'm running Vectorworks 2019 SP2 on macOS 10.13.6 and the above workaround isn't working for me.


What I think is worth noting is that the Esc key and Cmd-period worked for me a short while earlier in the same session, but:

  • Restarting Vectorworks didn't restore it. 
  • Resetting Vectorworks Preferences didn't restore it either. 
  • Above workaround still not working for me. 

…so I'm starting to wonder if I imagined it. 

Edited by Jeremy Best
Update / More info
Link to comment
  • 0

I am having the same issue. Rendering Final Renderworks PREVIEW rendering will not stop! No key strokes work and you can't change the render mode. However when the preview has finished and the export image has starter the rendering stops with command (.). I have a new Imac Pro 10 core. No rendering speed improvements over my 10 year old Mac Pro 6 core. The speed is the same very slow and the only way to stop preview is to force quit Vectorworks in finder.


NOTE: the note above pertains to design layer rendering. When you create a viewport you have a cancel update button in the info window which works properly. However Final Quality rendering is still very slooooow. 10 cores and 64 GB wasted.

Screen Shot 2019-03-10 at 5.05.35 PM.png

Edited by rjtiedeman
  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...