Jump to content
  • 0

Unable to Save Palette Positions



I have always had issues with my basic and tool sets palettes going back to default positions. Every time I open up VW, it goes to default and I have to drag them to my desired positions. About every week or so I save palette positions just to see if it works, but it never does. This happens regardless of being on a single or double monitor setup. Pictures attached are before and after I drag the tool sets. How can I get this to work properly?before.thumb.png.54ced66e75432cdbae83ef20e9b61207.pngafter.thumb.png.ea4b281dd68941315fa82c9b72ff4b5f.png

Link to comment

7 answers to this question

Recommended Posts

  • 0

Do you by any chance use a 4k monitor? I've tried two different setups at 4k and neither of them works. The program window itself works fine, but palettes jump unpredictably at restart, and are not visible in the 2nd, 2k monitor. Or they disappear on the 2nd monitor after a while and cannot be found unless one unplugs the second display.



Link to comment
  • 0

Just thought this might be a moment to note an irritating bug I have noticed regarding Palette position saving _ this related mainly to two monitor set up I work with . 



Also related directly to position saving and Palette snapping ., which at least in my experience,  do not working use together , 


For a long period of time I dealt with the palettes on dual monitor set-up being thrown randomly onto one (main application) screen following VW reboot .... demanding the re-positionng of palettes on every application restart ,


VSS support here in UK could provide no obvious solution so I continued with this ..... until ...... 


I discovered this would only occurr with any palettes docked to each other ! Separate palettes would retain 2nd monitor location _ any palettes - tools / Object info/ navigation  etc docked to one and other would be forced to application (main) monitor on VW reboot . 


I can deal with this quite easily but it does sort of make the whole palette docking feature a void in my case ..... 


VW 2018 & 19 Architect / Macpro / 2 X 27 " Apple displays ( one of which is Thunderbolt) .

Link to comment
  • 0
  • Vectorworks, Inc Employee

Hi @NicoleD,


I used to have the same problem, and I found that somehow my User Folder directory was messed up. What I did to fix it was:

- Press Windows key + R, and type "regedit" in the dialog and hit OK.

- Once the "Registry Editor" window opens, go to this directory: Computer\HKEY_CURRENT_USER\Software\Nemetschek\Vectorworks 23\General

- On the right side of the window, make sure that you have your User Folder directory be something like this: C:\Users\YOUR_USERNAME\AppData\Roaming\Nemetschek\Vectorworks\2018\

- Restart VW and try to save the palette positions again.


I hope it helps!



  • Like 1
Link to comment
  • 0
  • Vectorworks, Inc Employee
39 minutes ago, NicoleD said:

Unfortunately it didn't do anything for my basic/tool sets & attributes palette.

I'm sorry it doesn't work for you.


39 minutes ago, NicoleD said:

I'm thinking that maybe this might be fixed by going to 2019?

Yes it should. I've been saving the palette positions in VW2019 without any problems.

  • Like 1
Link to comment
  • 0

I realise this is an old thread, but I had the same problem, and this was the only thing I could find on the subject when googling.  I’m posting a solution here in case it’s of help to anyone else.


I am using VW 2017, but may work for other versions.


After 5 years using VW without issue, it suddenly started reverting to wacky pallet positions every time on loading.  “Save pallet positions” did not help.


I tried deleting the Architect.vww workspace file, but when VW saved the desired workspace, creating a new file, it had the same problem and reverted to crazy on reload.


The solution that worked was to create a new workspace in



I simply made a copy of “Architect.vww” in the Workspaces folder, then renamed it.  In Vectorworks, go to Tools > Workspaces, and select your new workspace, (Restart VW if it is not in the list.)  Then arrange your pallets and save your pallet positions.  The message should tell you it’s saved under the new workspace file you created.


This was the only solution that worked for me.  Must be some sort of corruption with the way it writes the default Architect.vww file?

  • Like 2
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...