Jump to content
Kingstone

Open GL vs Realistic Interior fast

Recommended Posts

2 minutes ago, ReXeR said:

Open GL shadows present but Realistic Interior Fast no shadows?

Test render 080918.vwxCouldn't find revision of post so ill reply here.  One heliodon in file all other lighting sources turned off.

Share this post


Link to post

Many thanks, I moved the furniture out of the room, and it actually displays shadow on the outside of the wall.  I think for the default rendering setting there should be a set to default button since in one's adjustments for the right final look can complicate things.

Share this post


Link to post

I noticed in your file that all textures are set to receiving no shadows and all of them have no preview. I assume at some point you created a texture from an image? That triggered a problem and corrupted the rest of the materials. I know the solution here is to transfer all to a new fresh file but the steps for transferring the materials  I'll have a ask my friends over here.

Screen Shot 2018-08-10 at 10.18.12 AM.png

Screen Shot 2018-08-10 at 10.19.17 AM.png

Screen Shot 2018-08-10 at 10.19.47 AM.png

  • Like 1

Share this post


Link to post

The problem is not with the rendering styles, it has to do with materials. Also, I noticed you added an image to the glass, something that looks wavy, frosted. I'd recommend you make use of noise-turbulence and increase the size to 400%, that'll get you the effect you are looking for.

  • Like 2

Share this post


Link to post

I spent some time with the file yesterday and couldn't solve it. I did have success pasting the geometry into a clean file. It wasn't the only thing I did so in the end I couldn't replicate my success a second time. Things I noted -

  1. The shadow was very faint in my one success.
  2. I tried making the glass panes thinner (its set to 1"), changing textures and finally making the panels empty. None of these fixed the issue.
  3. I never could get it to work in Realistic Interior Fast, even in a clean file where the Renderworks style was newly added. I only had it working in Realistic Exterior Fast.
  4. I toggled the Heliodon location, time of day and Renderworks Only options.
  5. I think it may have something to do with the background, since when it finally rendered properly the background was very different than in the other attempts.

Kevin

Share this post


Link to post

Hahaha, that is funny those materials are from Vectorworks default layout furniture.  Why is the storefront wall is not admitting those shadows into the room is part of the mystery.  I am currently working on inserting all objects into another new drawing without the default furniture setup I downloaded into the existing drawing.  We will figure it out of this i am sure.  Thanks.

Share this post


Link to post

Try not to use that same glass material. Use other simpler glass textures, no images.

Share this post


Link to post

I took a look at your file and it seems that its in the textures, which when after you edit them revert back to the same state they were before....

 

Odd!

  • Like 1

Share this post


Link to post

Please delete furniture, which is a grouped and may be an issue in itself, out of the drawing and start with a fresh new file,  just copy and paste Vectorworks walls and floor.  That should make it cleaner to inspect?

Share this post


Link to post
4 hours ago, markdd said:

I took a look at your file and it seems that its in the textures, which when after you edit them revert back to the same state they were before....

 

Odd!

 

Yes, the sample object size in the Texture dialog also is resetting to a size of zero. I remember another thread with this issue. I wonder if they're related.

 

Kevin

 

Share this post


Link to post
19 hours ago, Luis M Ruiz said:

The problem is not with the rendering styles, it has to do with materials. Also, I noticed you added an image to the glass, something that looks wavy, frosted. I'd recommend you make use of noise-turbulence and increase the size to 400%, that'll get you the effect you are looking for.

I follow the Forum on Mobile to beta test new iOS quirks. 

 

Used Nomad uploading the file vis GoogleDrive & put it on my coffee table. I saw all textures on materials in both walkthrough and AR. Walls have shadows, but there is no floor. Funny thing, I could click on the glass to make it transparent… Don’t know if that is a bug or a feature, but it looked kinda cool! 

 

Looks like your render settings were a big help to do so!

  • Like 1

Share this post


Link to post

Luis, Mark & Evan,  If you duplicate my simple setup, concrete wall, bamboo floor and storefront wall from scratch and finalize a rendering with Realistic Interior Fast shadows I would appreciate attaching the file for my review.  Thank you again for the continuing efforts.

Share this post


Link to post
On 8/9/2018 at 7:14 PM, Kingstone said:

Couldn't find revision of post

 

Help for next time..

 

1547843714_ScreenShot2018-08-12at14_34_34.thumb.png.bff8efe075e72d298ff3db2de85d4126.png

 

 

Share this post


Link to post

I was wondering why a wall in 'object mode' receives rendered shadows, but the same wall in 'component mode' does not.  The default textures of the component parts of Vectorworks walls seem to be resisting edit.  You can see this issue in the two viewports on the sheet layer of this 55 MB file.  Of which i am now having a problem uploading?

Edited by Kingstone
File not uploading

Share this post


Link to post

This looks like a corrupt file in the debugger. I can't even create new textures in this file. Can you create a new RW texture?

We need the steps that lead to this corruption. I've heard from some that textures stop responding to changes after an image texture is created, but this is not confirmed. Could it be something like this?

  • Like 1

Share this post


Link to post

Here are contents from Tech Support email concerning this issue:

 

"It looks like the issue is linked to an error that is occurring in the file.  It appears as though the textures on the wall are “breaking” and the ability for them to receive shadows is being disabled by something in the file.

At this time we cannot figure out what it is, but we are working with our engineers to determine what could cause the issues.

My best suggestion at this time is to remove the texture from your walls in the viewport (specifically the one that you are trying to display the shadows on)

Let me know if you have any questions,

Thanks,"

 

If this issue exists with components that I inserted from Vectorworks, I hope it get resolved quickly.   I looked at some of my older files with more or less the same content and shadow rendering seems to be fine with walls in component mode.  The real test is for anyone to create their own file from scratch in order for me to eliminate the fact that only my files are all corrupt.

Edited by Kingstone
additional thoughts

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×