Jump to content

Can Renderworks do solid fill in section view?


line-weight

Recommended Posts

I've created a sectional DLVP. You can see this rendered in OpenGL as I want it - with the section cut filled in solid.

 

But when I make a Sheet Layer VP, looking at this sectional DVLP, and do a Renderworks render on it, everything is shown as if hollow.

 

Is there any way of getting the Renderworks view to make things solid in section, as they are in OpenGL?

 

1673600924_ScreenShot2018-08-03at10_39_02.thumb.jpg.4155615a9281f5fa09d07df3051e80ae.jpg1095251565_ScreenShot2018-08-03at10_39_42.thumb.jpg.8a55e95766daf8717341e3fd8c30d476.jpg

Link to comment

I seem to remember this being an issue in previous versions, but I've just check on a very simple section viewport is 2018 an all is working fine. In previous versions I seem to remember needing to make sure that Display Planar objects was checked in the OIP. Also, do you have the Section Style Class active in the DLVP?

Link to comment
1 hour ago, markdd said:

make sure that Display Planar objects was checked in the OIP. Also, do you have the Section Style Class active in the DLVP?

 

Thanks, have tried both of these... but no joy sadly.

 

I've just tried making a new file with nothing but a simple cube in it - but getting the same results.

 

 

Screen Shot 2018-08-03 at 11.58.21.jpg

Edited by line-weight
Link to comment

If I use the basic custom renderworks style, I get the same.

 

However, if I change the 'indirect lighting' settings to anything other than 'none', it stops showing the section plane and I get a hollow cube again.

 

The same applies to the preset renderworks style "realistic exterior fast" - turning 'indirect lighting' settings from 'none' to anything else loses the section plane.

 

...in fact the same seems to apply to all renderworks styles as far as I can see.

Edited by line-weight
Link to comment

I remember this from another instance about 6 months ago, however I had forgotten about it! I reported the bug then, but obviously its not made it to the top of the list yet. There is a workaround which involves:

  • duplicating the design layer and
  • turning off "display objects beyond view pane" on the duplicated viewport so you just see the edge that you were missing before
  • In the sheet layer duplicate your viewport
  • in the duplicated viewport, just set the third layer to be visible and render in Wireframe
  • Align the viewports on top of each other!

Phew! But it does work!

Screen Shot 2018-08-03 at 14.35.29.png

Cut Plane.vwx

Edited by markdd
Link to comment
2 hours ago, markdd said:

I remember this from another instance about 6 months ago, however I had forgotten about it! I reported the bug then, but obviously its not made it to the top of the list yet. There is a workaround which involves:

  • duplicating the design layer and
  • turning off "display objects beyond view pane" on the duplicated viewport so you just see the edge that you were missing before
  • In the sheet layer duplicate your viewport
  • in the duplicated viewport, just set the third layer to be visible and render in Wireframe
  • Align the viewports on top of each other!

Phew! But it does work!

Screen Shot 2018-08-03 at 14.35.29.png

Cut Plane.vwx

 

Ok, thanks. I'd wondered if something like that might work.

 

I wonder if this is one of those bugs we'll never see fixed.

Link to comment
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...