Jump to content
  • 0
Marconi

VW2018 Vanishing objects in rendering?

Question

Hello,

 

I'm having a seemingly funky rendering issue across multiple files. I'm running VW Spotlight 2018 SP4 and am unable to render in Final Renderworks or as Custom Renderworks. Its as if the operation never starts and all my objects, symbols, etc. become transparent (as in they become invisable). Everything is still selectable and appears with an orange outline when selected. Also of note is that when I zoom in and out with the mouse, I am able to briefly see all objects crudely rendered. However, the moment I release the mouse when zooming to lock in a view, all objects revert to their incognito modes and disappear once again. Open GL rendering seems to work just fine. File uploaded below 

 

I cant find anything else about this problem on the forums, so I know I'm missing something. Or perhaps I'm just a victim of not enough GPU for VW? Any thoughts would be appreciated.

 

Specs:

MacBook Pro 10.13.6 (13-inch, 2016) 

2.9 GHz Intel Core i5

8 GB 2133 MHz LPDDR3

Intel Iris Graphics 550 1536 MB

 

Running VW2018 Spotlight

Chandelierv1.vwx

Share this post


Link to post

Recommended Posts

  • 0

Both Fast Renderworks and Final quality Renderworks will take a few seconds/minutes to render this file. Zooming in and out while rendering will will make matters worse. Have you left the file to render for a few minutes?

 

It renders fine here, so its probably not the file. Your computer is a few years old so maybe there is a hardware issue, however there shouldn't be. 

 

The standard procedure would be to render from a Sheet Layer viewport as it gives you much better control over the quality of the output and also the rendering style. Rendering the whole screen is often tempting for a test render or two but its best to then render from Viewports after that.

 

Come back if you have any more questions

 

 

Share this post


Link to post
  • 0

I suspect its gotta be a hardware issue. It's as if the rendering operation never initializes when I select either of those options. No status bar and I'm able to freely select objects (something I cant do when running other rendering options). Almost as if VW is looking at my measly graphics card and just saying "nope!" Strange that I don't get any kind of notification pop-up though. Thanks for taking the time to look at the file.

Share this post


Link to post
  • 0

Has this always happened with this hardware, or did it just start suddenly? If it just started, does the same thing happen after a full machine restart?

  • Like 1

Share this post


Link to post
  • 0

TBH Jim, this is the first I'm noticing the issue. However, this hardware is relatively new to me (still gotta update my old tag) and this is my first time trying to do a full render on this machine. I'll give an update after I try a full system restart around lunch time when I can afford the time to do it. 

Share this post


Link to post
  • 0

@Jim Wilson I tried a full system reset and reboot, but got the same results. Still seems as if the rendering isn't initializing when I select fast, final, custom, or artistic rendering options. Directional view changes, zooms, and flyovers produce Open GL grade rendering briefly while the view is moving/zooming before reverting to transparent objects. I'm stumped. If anyone else has experienced this, please chime in and add your two cents.

Share this post


Link to post
  • 0

@Marconi Did you try and render the file on a different machine?

I often find my students struggling with lots of imported items from exernal libraries that are not made with Vectorworks. Seems that applied textures to symbols or groups with (too many) many 3D polygons won’t make the video card happy…

Share this post


Link to post
  • 0
20 hours ago, Marconi said:

Everything is still selectable and appears with an orange outline when selected

 

That was always the case in DL Viewport and ruined a lot of my screenshot attempts.

 

Selection and Highlighting of objects in RW Rendered screen views may not be very

useful but at least it doing so does not seem to destroy the Rendering.

 

But View changes like rotating or zooming causes a re-rendering.

And I think that makes sense ....

 

  • Like 1

Share this post


Link to post
  • 0

Those integrated graphics cards are a problem. Ironically the NVIDIA GeForce GT 650M 1024 MB in my 2012 MacBook Pro seems to still perform just fine most of the time. Your file renders fine here.

 

What's Preferences>Display>Navigation Graphics set to? Have you tried adjusting it? I also work with Preferences>Interactive>Cursor pre-selection highlighting turned off. With geometry heavy files it can be an issue.

 

Another solution would be to render to a sheet layer viewport for your higher quality renderings and just use OpenGL for working. May not be ideal though if you're visualizing lighting.

 

Kevin

 

  • Like 1

Share this post


Link to post
  • 0
23 hours ago, Marconi said:

However, this hardware is relatively new to me (still gotta update my old tag) and this is my first time trying to do a full render on this machine

What machine are you actually using?

Share this post


Link to post
  • 0

@markdd 

Specs:

MacBook Pro 10.13.6 (13-inch, 2016) 

2.9 GHz Intel Core i5

8 GB 2133 MHz LPDDR3

Intel Iris Graphics 550 1536 MB

 

Running VW2018 Spotlight SP4

Share this post


Link to post
  • 0

I agree with many above that hardware is probably the culprit here. InterestinglyI had no issues with my old 2012 Mac book (which also utilized an integrated graphics card). I'm still left wondering why VW itself would not notify me of any performance issues in the software when an inaccessible operation was selected. I understand that there are several different tiers of recommended hardware profiles, but encountering this issue with no in-software notification or explanation seems...incorrect. It makes me think that I'm experiencing a bug. Thankfully, this forum is a great sounding board and extremely responsive  so I'm not left searching too long for answers. Guess I'm in the market for a new machine with a dedicated graphics card.

Share this post


Link to post
  • 0
On 7/27/2018 at 3:38 PM, Marconi said:

Also of note is that when I zoom in and out with the mouse, I am able to briefly see all objects crudely rendered

Please forgive this question, but just to confirm; you are not trying to navigate around the model while simultaneously trying to render in Fast Renderworks or any other Renderworks state? Open GL is the only render mode that will support navigation around the model.

 

In VWX preferences, have you tried reducing your Navigation Graphics setting to "Good Performance and Compatibility".....

Share this post


Link to post
  • 0

@markdd 

19 minutes ago, markdd said:

Please forgive this question, but just to confirm; you are not trying to navigate around the model while simultaneously trying to render in Fast Renderworks or any other Renderworks state? Open GL is the only render mode that will support navigation around the model.

 

In VWX preferences, have you tried reducing your Navigation Graphics setting to "Good Performance and Compatibility".....

Correct. I am NOT attempting to navigate while rendering. I am simply navigating through the drawing after it has become obvious that the rendering is not initializing (no status bar, etc.) 

 

And yes, at the recommendation of @Kevin McAllister I did modify those graphics settings with no noticeable change in performance unfortunately.

 

Share this post


Link to post
  • 0

Any chance you could make a screen shot of what's happening?

  • Like 1

Share this post


Link to post
  • 0
12 minutes ago, Marconi said:

@markdd 

Correct. I am NOT attempting to navigate while rendering. I am simply navigating through the drawing after it has become obvious that the rendering is not initializing (no status bar, etc.) 

 

And yes, at the recommendation of @Kevin McAllister I did modify those graphics settings with no noticeable change in performance unfortunately.

 

 

If you're not navigating around the model and its purely about whether a Renderworks mode starts rendering or not then it may be an installation issue. Renderworks is CPU based so your GPU shouldn't much matter. Does it happen in all your files or just this one? If it only happens in this file, have you tried cutting/pasting your work into a clean file to see if it helps? Ultimately I would try resetting your user preferences - link

 

IMPORTANT - Personally I would make a backup of my old user folder first (usually dragging the old one to the Desktop rather than deleting it). That way you can restore it or copy over anything you might want like custom workspaces. Always back up before troubleshooting and always test on copies of your original files.

 

Kevin

 

 

Share this post


Link to post
  • 0

@markdd  ,

 

Sure! here's a quick and dirty screen capture video to illustrate. I start in wireframe, render in OpenGL, and then attempt to render in fast renderworks. I then illustrate the flyover "ghosting" of all objects and symbols. At the end I show my display preferences for those curious. Again, I really appreciate the amount of feedback and input I'm receiving. Definitely the silver lining of this issue 🙂

Share this post


Link to post
  • 0

There have been some strange "caching" issues with Fast Renderworks that I have noticed over the last few months.

 

Have you tried do a Custom Renderworks render (all settings at low) and also a complete re-boot of your laptop?

 

Mark

Share this post


Link to post
  • 0
55 minutes ago, Marconi said:

@markdd  ,

 

Sure! here's a quick and dirty screen capture video to illustrate. I start in wireframe, render in OpenGL, and then attempt to render in fast renderworks. I then illustrate the flyover "ghosting" of all objects and symbols. At the end I show my display preferences for those curious. Again, I really appreciate the amount of feedback and input I'm receiving. Definitely the silver lining of this issue 🙂

 

Was that Renderworks background in the original file you posted? It doesn't show up when I render your file. It makes me wonder if the background resource is corrupted.....

 

I also agree with Mark, avoid Fast Renderworks (and Final Quality Renderworks for that matter). In another thread there was a discussion about how they haven't been given development attention in recent versions. Stick to Custom Renderworks styles as they will give you better results.

 

Kevin

 

 

Share this post


Link to post
  • 0

Thanks @Kevin McAllister & @markdd . I've tried all of your suggestions and still have the same results. The last thing I can think of is to do a full re-install of VW and see if it is indeed a weird installation fluke. Otherwise, I'm at a loss. Btw Custom renderworks performs exactly as you saw in the video even with all settings at low. 

 

Share this post


Link to post
  • 0

@Marconi Maybe you won’t have to reinstall the complete app. This might work in your case as well:

 

- Close Vectorworks 2018. 

- In the Finder menu bar goto Go with ALT key pressed and choose Library.

- Delete (or better: move to new folder onto desktop) the .plist files associated with VW2018 that are located in the Preferences folder.

- Restart laptop & log in. 

- Restart Vectorworks app. 

- open just that one drawing, no other tabs. 

 

Good chance rendering will go fine.

I hope… 😉

Edited by Jan-Burger TROOST
Adding last step

Share this post


Link to post
  • 0

@Jan-Burger TROOST So I gave your trick a shot and upon rebooting and discovered something had changed. Artistic, fast, final, and custom renderworks are now no longer selectable options. I'll restore all the deleted .plist files and see if I can recreate this issue.

 

Screen Shot 2018-07-28 at 4.23.27 PM.png

Share this post


Link to post
  • 0

@Marconi Weird! It’s like the link within VW to RW is broken. I used to wait as long as I could reinstalling my copy of VW, since all the custom prefs and workspaces had to be done again as well…

 

And what would happen if you’d make a new user and do a clean install? Maybe some other programs you have interfer with RW🤷‍♂️

Share this post


Link to post
  • 0

As a final offering, I noticed that all your lighting devices are tuned on. Can I suggest that you turn them off and also turn off the beam geometry as well. Then give that a try..... 

Share this post


Link to post
  • 0

Just posting a final observation. After completing a full re-installation of VW 2018 I have exhausted all options that I know of to sort this problem out. Nothing has improved and I am still unable to render my drawing(s) as desired. If this isn't a bug than perhaps its just a nasty way of finding out I need a better laptop to render my drawings. Shame. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×