Jump to content
Sam Jones

NumCustomObjectChoices(pioName, pParamName)

Recommended Posts

It seems that I am unable to get "NumCustomObjectChoices(pioName, pParamName)” to yield anything but “0” When it queries a dynamically loaded dropdown.  


The “AP Multicable” plug-in object has a “Break Out Type” field that is loaded from an XML.  There are AP Multicables on the drawing and the Preferences OIP shows all the choices, but NumCustomObjectChoices('AP Multicable', PBreak_Out_Type) yields “0”.

 

The function description says to use the PForm of the parameter as I do above, but I have also tried it with “ Break Out Type” with the same result.  The function is used in a selection procedure and not in an object.  What am I doing wrong, or am I just screwed?

TIA,
 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...