Jump to content
Jasonbrett

All lighting fixtures are black

Recommended Posts

Hi there. I'm very new to vectorworks but have a issue I can't figure it out. All my 3D lighting fixtures are just a plain black in OpenGL and final quality rendtrworks. There's no real detail to them. Is this normal? 

Also, when I insert some tomcat truss it looks good. Once I add any lighting fixture to the drawing that truss suddenly becomes dark and loses it's nice detail in those two viewing options. What am I doing wrong!! I've attached an example. 

VW Example.pdf

Share this post


Link to post

Hey Jason, welcome to VW! Looks like your jpg is rendered. Truss shows silver cause it has a silver texture. Fixtures render black bc there is no ambient light. This is norm. If u zoom up to the fixture, should look normal. Are you trying to make an image for a pitch and want them to look 'IRL'?  See if this helps

 

 http://app-help.vectorworks.net/2016/eng/VW2016_Guide/Rendering/Ambient_Light_and_Sunlight.htm  

 

If it doesnt matter, leave it alone.  Making it look pretty in render mode just wastes resources,  chews up CPU and GPU 

Share this post


Link to post

Thanks for the response Tim. Unfortunately that didn't fix the issue.  I attached a OpenGL Render zoomed in tight after I cranked up the ambient light. 

Screen Shot 2018-07-20 at 7.35.17 PM.png

Share this post


Link to post

This what the Truss looks like before I add any lighting fixtures. As soon as I do that, it turns to a really unrealistic looking gray. 

Screen Shot 2018-07-20 at 7.39.24 PM.png

Share this post


Link to post

When a drawing doesn’t contain any render lights, VW places a directional light over your virtual left shoulder. As soon as you add a light object, VS assumes you are lighting with intention and turns off this “work light”. 

Lighting devices contain render lights, do as soon as you insert one, the default light goes out. 

To give yourself some light, add a directional render light from the visualization palette. 

Ambient light really just sets the Black point of shadows, so while it helps you see dark objects, you don’t get any modeling cues. 

Share this post


Link to post

Like I said, I'm new at this. What do you mean by add a directional render light? I don't see how to do that within the visualization palette? 

 

Thank you in advance! 

Share this post


Link to post

Sorry, I should have said the visualization Tool Set, the one with the light bulb icon. The tool set has a tool with a similar icon. 

 

With the tool selected, look in the mode bar (tool options at top-left of the window), and make sure the one that looks like the sun is selected. Click to place this in the drawing.

 

For ease of control, I often put the light on its own layer. The layer visibility will turn the light on or off. I can also then import the layer into other drawings, making sure the option to support layer objects is selected. 

Share this post


Link to post

Hi Jason, I had a chance just now to mess around with this a bit.  If you've found the visualization tool set, and placed a light tool (that looks like a light bulb) on the drawing, say at a 50' z height, and still see black fixtures, then the symbol has been drawn with a black fill.  

 

To change that, find the symbol reference in your resources browser, right-click and choose 'edit 3d'.  select all, and ungroup until you've reached the point where you have objects instead of groups.  Then, go ahead and fire up opengl rendering so you can see what your symbol will look like.  go to the attribute palette, and under the bucket icon change the color from black to whatever you want.  The symbol should re-render at that time and I go ahead and group them back up again.  when you choose exit then all instances of the symbol should change.  if they don't, try refreshing instruments.  Here's a screen shot of the attributes palette.

 

This is why most people keep a favorites file of symbols that they've modified to fit their own situation.

 

peace,

 

TimO

attrib.JPG

Share this post


Link to post
Quote

 

To change that, find the symbol reference in your resources browser, right-click and choose 'edit 3d'.  select all, and ungroup until you've reached the point where you have objects instead of groups.  Then, go ahead and fire up opengl rendering so you can see what your symbol will look like.  go to the attribute palette, and under the bucket icon change the color from black to whatever you want.  The symbol should re-render at that time and I go ahead and group them back up again.  when you choose exit then all instances of the symbol should change.  if they don't, try refreshing instruments.  Here's a screen shot of the attributes palette.

 

 

I wouldn't recommend ungrouping anything, as this may affect Record Formats that are attached to various things in order to make Lights function properly in Spotlight. Instead, just double click groups to go inside them and edit the contents.

 

Beyond that, the notion that the objects may have a black fill is probably correct. Actual black black will always render as completely black regardless of lighting in your scene, so for the most part true black fills should be avoided in rendering situations. "Black" things should instead get a 90% or 95% grey fill so that they have at least a little shading.

 

Note that before looking at the Attributes Palette with the objects selected, first check the Render Tab of the OIP to see if there's a Texture applied (since this overrides the fill color). If so, then check the settings for that texture. Most of the VW default content comes in with a texture called "Default Instrument Texture" which actually has a color of Cool Black 90%.

 

Let us know if this helps!

 

 

Share this post


Link to post

since 99.9% of fixtures on the market are black in color, the VW content is created that way too.  we don't put all the fins and sweeping corners on the fixtures as this creates more surfaces to render and when you start having huge number of fixtures in a drawing, can severely affect rendering time.  The VW libraries also ship with a silver and White default instrument texture that you can swap out if you want a silver or White instrument.  you will need to go into the symbol 3D and change it from the default(Black) to what you want.  

What I am really curious on is why you think they need to be a different color?  

Share this post


Link to post

Hi Rob, 

 

Thanks for the response. I don't need a different color. My problem was fixed above with adding ambient light. I didn't realize that when you add a lighting fixture, it automatically assumes that's the only lighting source and defaults everything to a dark look. After adding that, everything looks far better. My fixtures still look black and I was hoping for a more realistic look, but it's not that big of a deal. 

Galantis Right ISO.jpg

Share this post


Link to post

There a  few situations where I've wanted the rendered fixtures to be different than black; for example, a plot I received from the designer that had hundreds of fixtures AND those fixture placements were in various positions, many directly under others.  Even with wireframe 3d, it was difficult to gain the detail I needed to engineer the plot.  Black fixtues are basically blobs of black, and when the fixture density is high it was important to me to be certain that I didn't miss anything.  I changed those fixtures to white and, for me, the decrease in visual confusion was a huge help.

 

I could also see if someone were to work up a rendering that included fixtures, and wanted them to be more visible against the background

Share this post


Link to post
27 minutes ago, Tim Olson said:

There a  few situations where I've wanted the rendered fixtures to be different than black; for example, a plot I received from the designer that had hundreds of fixtures AND those fixture placements were in various positions, many directly under others.  Even with wireframe 3d, it was difficult to gain the detail I needed to engineer the plot.  Black fixtues are basically blobs of black, and when the fixture density is high it was important to me to be certain that I didn't miss anything.  I changed those fixtures to white and, for me, the decrease in visual confusion was a huge help.

 

I could also see if someone were to work up a rendering that included fixtures, and wanted them to be more visible against the background

 

If you just want to make things clearer while you work with the model, you could also go to View>Rendering>OpenGL Options and adjust your design layer render settings. Turning off "Use Textures" and "Use Colors" can often help with the visibility of model geometry.

 

Kevin

 

Share this post


Link to post
4 hours ago, Kevin McAllister said:

If you just want to make things clearer while you work with the model, you could also go to View>Rendering>OpenGL Options and adjust your design layer render settings. Turning off "Use Textures" and "Use Colors" can often help with the visibility of model geometry.

 

@Jasonbrett Or why not edit the Instrument texture to 70% grey. That works well. Its easy enough to put the texture back to  black again. Just remember to refresh the instruments to see the change.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...