Jump to content
PVA - Jim

macOS Mojave (10.14) Compatibility

Recommended Posts

5 minutes ago, ODHW said:

 

That's right AD, SP1.1. 

 

No idea how, but I get the spinning beachball when I draw lines without the hard drive, and works absolutely fine when I plug it in! 

 

It's a cheap USB powered 1Tb drive. 

 

The files are on my integral hard drive of course– I'm running absolutely nothing off the hard drive.

 

Anyone else getting this?

 

O

I was having a lot of issues with SP1, and found that unplugging everything from my computer fixed them.  Through process of elimination, it turned out to by my Wacom tablet.  If its connected via Bluetooth, no issues with VW2019 on Mojave.  When its connected via USB, VW hangs.  Seems like maybe VW and Mojave are having problems with USB communication in general.  

  • Like 2

Share this post


Link to post

Hi, 

 

I am using Vectorworks 2016 and I have recently updated to Mojave 10.14. Vectorworks is crashing whenever I try to use or open a file - is there any way to fix this issue for Vectorworks 2016?

 

Any help would be greatly appreciated!

Share this post


Link to post
44 minutes ago, Lee Marable said:

Hi, 

 

I am using Vectorworks 2016 and I have recently updated to Mojave 10.14. Vectorworks is crashing whenever I try to use or open a file - is there any way to fix this issue for Vectorworks 2016?

 

Any help would be greatly appreciated!

Vectorworks has said they will not be releasing updates or fixes for anything older than 2018.  You'll either need to upgrade your VW to 2018 or 2019 or take your macOS back. 

  • Like 1

Share this post


Link to post
On 11/9/2018 at 4:07 PM, BryanNaegele said:

When its connected via USB, VW hangs.  Seems like maybe VW and Mojave are having problems with USB communication in general.  

 

Same here,

USB Problems here from time to time (1 Minute hangs)

Not only my Wacom Cintiq input, also 3DConnexion or any other input device.

0-1 times a day.

But much more often when VW open.

Share this post


Link to post

I have a Wacom tablet and 3DConnextion USB devices.  Jesus!!  Haven't upgraded to Mojave yet waiting for the all clear.  Its been a long wait, I wonder if Nemetchek is feeling like some second class citizen.

Share this post


Link to post
12 minutes ago, Kingstone said:

I have a Wacom tablet and 3DConnextion USB devices.  Jesus!!  Haven't upgraded to Mojave yet waiting for the all clear.  Its been a long wait, I wonder if Nemetchek is feeling like some second class citizen.

My 3D mouse has been ok with VW, but it seems to lose connection and have to be unplugged and reconnected. This is new to Mojave. 

Share this post


Link to post

My 3D Connexion Spacemouse Enterprise loses connection randomly on High Sierra. I simply unplug it and plug it back in to give it a reboot. 

 

This happens inside and outside of Vectorworks. 

 

In some instances with Apple’s OS, USB connected devices can cause issues upon computer boot up. Of course it’s not always feasible to always have all your USB devices unplugged during boot up. 

 

Rob

Edited by rgcn

Share this post


Link to post

It’s funny you mention that @rgcn because  I have noticed the exact same thing with my 3D Connexion Spacemouse. I didn’t have this connection “hiccup” in (low) Sierra but I do see it in High Sierra. It’s not surprising to hear it’s occurring for some people in Mojave. My hope is that Apple has provided enough information to the companies that make external devices so that those companies can update their device drivers as needed.

 

Personally I’m in no hurry to upgrade my Mac OS to 10.14 Mojave... I have yet to see anything listed for Mojave’s new features and enhancements that is mission critical for getting my work done. 

Share this post


Link to post

Every time I startup/reboot High Sierra I have to unplug, and then replug my 3Dconnexion CadMouse. I've emailed 3Dconnexion but their tech support is awful, so I just live with it. Good to know I'm not the only one having I/O issues with their products on a Mac (they prioritize Windows because their core focus is MCAD).

  • Like 1

Share this post


Link to post
17 minutes ago, Mark Aceto said:

Every time I startup/reboot High Sierra I have to unplug, and then replug my 3Dconnexion CadMouse. I've emailed 3Dconnexion but their tech support is awful, so I just live with it. Good to know I'm not the only one having I/O issues with their products on a Mac (they prioritize Windows because their core focus is MCAD).

 

Yes, 3DConnexion’s tech support is awful. I have emailed them many times over the years with issues , and I think I have only received one response. 

 

Rob

Share this post


Link to post

3Dconnexion released a driver update on 10/31 with added support for Mojave if that helps anyone (didn't solve my reboot issue on HS):

 

https://www.3dconnexion.com/service/drivers.html

 

Version 10.6.0 (r2876; October 19, 2018). First public release of version 10.8.

  • New: 3DxMacCore v. 1.0.0 (b32, e88f6db; Oct 19, 2018).
  • Updated: 3DxAcrobat3D v. 1.1.2 (r710; Oct 5, 2018).
  • Updated: 3DxCollage v. 1.1.0 (r15444; Oct 16, 2018).
  • Updated: 3DxMaya v. 4.5.1 (r15417; Oct 8, 2018).
  • Updated: 3DxNLServer v. 1.3.1 (r15387; Oct 1, 2018).
  • Updated: 3DxPair v. 2.2.0 (r15446; Oct 16, 2018).
  • Updated: 3DxPuzzle v. 1.0.6 (r15445; Oct 16, 2018).
  • Updated: 3DxPhotoshop v. 2.9.0 (r15412; Oct 5, 2018).
  • Updated: 3DxSketchUp v. 4.6.0 (r15411, branches/4; Oct 5, 2018).
  • Updated: 3DxTrainer v. 1.0.5 (r15443; Oct 16, 2018).
  • Updated: 3DxViewer v. 2.0.13 (r15441; Oct 16, 2018).
  • Removed: 3DPackage (replaced by 3DxMacCore).
  • New: [MAC-56] Add support for Apple macOS 10.14 ("Mojave").
  • New: [MAC-58] Added support for Adobe Photoshop CC 2018.
  • Fix: Removing a page via <Delete> key did not update the view in Collage.
  • Change: 3DxDemo now also opens on machines with no OpenGL acceleration. Demo
  • now also uses FSAA to improve rendering quality.
  • Change: Removed support for 32-bit editions of Trimble SketchUp. Minimum supported
  • SketchUp version is 2015 (64-bit).
  • Note: 3DxMacCore replaces the "3DPackage" component and includes 3DxDemo,
  • 3DxNumpad, 3DxRadialMenu, 3DxSNAxisDemo and 3DxVirtualLCD.
  • Like 2

Share this post


Link to post

Hi all, I've been waiting to upgrade my mac os to Mojave until i was sure i could use 2018 and/or 2019. Is there any updates on this? TIA.

John

Share this post


Link to post
16 minutes ago, jgmrussell said:

Hi all, I've been waiting to upgrade my mac os to Mojave until i was sure i could use 2018 and/or 2019. Is there any updates on this? TIA.

John

 

Expect one shortly.

Share this post


Link to post
7 minutes ago, SVA Architects said:

The 2D arc tool radius mode still produce a spinning beachball for appx 10mins.  OSX Mojave VW 2019 SP2 downloaded today 😞

 

Doesn't happen to me

Share this post


Link to post
12 minutes ago, SVA Architects said:

The 2D arc tool radius mode still produce a spinning beachball for appx 10mins.  OSX Mojave VW 2019 SP2 downloaded today 😞

I'm still getting the spinning beachball for about 45 seconds every 4th or 5th action I take. Was hoping SP2 would fix, my productivity is seriously suffering. I hope there can be a resolution soon!

Share this post


Link to post

 

33 minutes ago, SVA Architects said:

The 2D arc tool radius mode still produce a spinning beachball for appx 10mins.  OSX Mojave VW 2019 SP2 downloaded today 😞

 

Me neither. I’m good. SP2 on Mojave. Freshly installed Mojave as of this morning. All working well so far. 

  • Like 2

Share this post


Link to post

All seems well on my system as well, with a 3D mouse and my Wacom tablet connected through USB so that seems to have been sorted out.  I did have to spend some time on the phone with Tech Support to upgrade from SP1 to SP1.1.  My updater was borked and we had to do a clean install and they had to send me some files directly.  If you haven't tried a clean install, that's the first thing I'd try, but SP2 seems to be stable and have fixed the issues I'd been seeing.

Share this post


Link to post
2 minutes ago, BryanNaegele said:

All seems well on my system as well, with a 3D mouse and my Wacom tablet connected through USB so that seems to have been sorted out.  I did have to spend some time on the phone with Tech Support to upgrade from SP1 to SP1.1.  My updater was borked and we had to do a clean install and they had to send me some files directly.  If you haven't tried a clean install, that's the first thing I'd try, but SP2 seems to be stable and have fixed the issues I'd been seeing.

Thanks for the advice. I'm learning the problem is inconsistent; for the past 15 mins all has been well. If it crops up again a clean install is my next step.

Share this post


Link to post

I would like to upgrade to Mojave, but I still use VW2017 to import Revit kitchen equipment files because importing doesn’t work properly on VW 2018 or 2019. Does anyone know if 2017 works well enough on Mojave to just import a Revit object and save the file?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×