Jump to content

Rendering problems

Recommended Posts



I have some rendering problems.

I have created this small file, where i want to make some renderings, but something seems to go wrong.


I have created a camera and created a viewport on this camera. I have then duplicated the viewport, so I have three of them and I have rendered them with three different styles.

But there is a differens in these. It looks like the perspektiv on the white line is strange on the fast and final q. also on the final q it seems like that the tiles are jumped a bit up?


This is Open GL render




This is fast q. render



This is final q. render



Link to comment

I have seen some geometry shift in different rendering modes before (like the tiles). I'm pretty sure its a bug. Please make sure you Bug Submit your file so this issue can be tracked down. You can Bug Submit here - link ( @Jim Wilson any progress on adding the Bug Submit link back to the forum template? )


I'm not sure what's happening with the other lines. Are any of the objects scaled symbols? If they are scaled symbols containing NURBS surfaces this type of stuff happens because the scaling breaks.


If you are able to post a portion of the file we may be able to help further.





Link to comment
10 hours ago, Mikedk64 said:

@Andy BroomellBut I still have the problem with the lines. also the "red, green, yellow" rectangles seems to disappear on the last two renderings.

I have attached a test file, where the problem is.



The issue is related to mixing planar object into a 3d scene. Planar objects aren't true 3d objects in VW and render differently. Fast Renderworks and Final Quality Renderworks are particularly susceptible to these problems as they haven't been updated for a few versions. The general consensus is to use a custom Renderworks Style instead.


I've attached an updated version of your test file. I took the planar objects and turned them all into extrudes of 1mm. You could of also converted them to NURBS surfaces (Command Option K on a Mac). I've also unchecked "Display Planar Objects" for each of the viewports. I wouldn't leave that on unless you truly need it. I may have missed converting a few of your objects and you may find that my 1mm extrusions need to be deeper for some render modes to get rid of interference between surfaces (the coloured squares in OpenGL for example).




(I had to turn off Save Viewport Cache in the file to make it small enough to upload.)


Test-4 KM.vwx

Edited by Kevin McAllister
  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...