Jump to content
B Butterbaugh

Viewing a stage in 3d OpenGL

Recommended Posts

I drafted a stage using the stage deck insert, pick the 3d Options button, and clicked the associating textures. However, my stage stays white in left isometric. It is in OpenGL, I have tried selecting the 3D options then a texture, I have tried leaving the 3D options set to black, and I have tried using fill color. It has remained white every time. Thoughts? (It has an orange frame in the pic because I have my mouse over it. There are actually several other decks there.)  Open GL options set to 'use texture' and 'use color' but no other choices are select-able.

Screenshot (2).png

Share this post


Link to post

This look to be in wireframe render, check your settings in Vectowks preferences.

 

 

1130066390_ScreenShot2018-06-05at7_18_00PM.thumb.png.ac6408b1458ec3dafd106b80a4c21a86.png

 

 

 

Share this post


Link to post

OpenGL is checked there. Same result. Anywhere else I might try? (Interesting development: when I use the wheel on my mouse, it pops up in black wireframe for a second or two.)

Screenshot (3).png

Share this post


Link to post

Two more spots than I would need to see your file and settings...

 

Number 1 check the render tab...

 

1529257459_ScreenShot2018-06-05at8_49_01PM.thumb.png.17c2312129158a8536d8c352085b036d.png

 

 

Number 2 the 3D options on the Stage deck

907338078_ScreenShot2018-06-05at8_49_43PM.thumb.png.987cec95d14a5fb4e8f6219e690ec3e2.png

 

 

Share this post


Link to post
5 hours ago, B Butterbaugh said:

(It has an orange frame in the pic because I have my mouse over it. There are actually several other decks there.)

 

Its a bit odd to have disappearing objects. If there are multiple objects in your screen shot and only the one with pre-selection highlighting (orange) is showing, it indicates to me this may not be a rendering issue. Things I would look at include -

 

- are the classes needed to show the object turned on?

- have you toggled the compatibility setting in Tools>Options>Vectorworks Preferences>Navigation Tab>Navigation Graphics. I would try setting it to "Best Compatibility".

- are your graphics drivers up-to-date?

- are you using an integrated graphics card? It may be underpowered for your needs.

 

Kevin

 

Share this post


Link to post
  • BradonSPP
  • Open GL is selected there too.  In the 3d options I have tried just plain black/silver as well as a texture. Neither took.

Screenshot (4).png

Screenshot (5).png

Share this post


Link to post

Kevin M 

I think you are right I have to have a setting of somewhere. 

-All Classes are visible

-I don't have a navigation tab.

-I am pretty sure my drivers are up to date. I will have to double check. 

-As for underpowered it has worked before on this laptop/vectorworks 2018 with truss and lighting equipment 

Screenshot (8).png

Screenshot (9).png

Share this post


Link to post

If I select all the decking and press and hold the center button on my mouse I can see the entire deck in wireframe. But the second I click out of it it disappears again. It is probably some silly setting I have off somewhere

Screenshot (7).png

Share this post


Link to post

If you create some simple solid extruded rectangles off to the side, do those objects behave as expected while the stage elements flicker or disappear, or do they all behave the same? Reply back with the following from your machine as well please:
 

 

Share this post


Link to post

Jim

I drew a 2d rectangle set the solid color to blue. The second I extruded it, the rectangle changed to not look solid. and in 3d it is just like rest.

Screenshot (10).png

Share this post


Link to post

The graphics card on this machine is an Intel HD 3000, with only 32MB of dedicated VRAM. Vectorworks requires 2GB of VRAM or above to function properly, and this could absolutely lead to OpenGL not behaving correctly on your machine.

There is a chance upgrading the graphics driver may help, but it looks like you may already have the latest one from about 3 years ago, and Intel hasn't released any newer versions since then:

https://downloadcenter.intel.com/download/24970/Intel-HD-Graphics-Driver-for-Windows-7-8-8-1-32bit?product=81500

Share this post


Link to post

Jim

Thanks. That is so weird. I know that at least wireframe has worked before with truss and moving lights. I tried setting this file to wireframe as well and it stillsdisappeared. It shows up as wireframe when I zoom in and out but it won't stay. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×