Jump to content

3D Rendering Hang-up

Recommended Posts

I just updated to VW 11.1 today. In Windows XP, I drew a 2D preliminary plan. Later, I tried to convert it to 3D for a quick look. I discovered that I can't globally set a Z+ dimension for all exterior walls. So I selected each element separately and added the wall height. The wireframe views worked OK, though a little slow according to my limited experience.

However, when I tried to render with Shaded Polygon or Fast RenderWorks, the computer hung up. The screen turns white, except for the VW11 header. The hourglass displays for a long time. So I gave up and tried to quit the render by typing Control + Period, or Escape. Then on the upper right of the white screen, I saw the progress bar: "Destroy List". Later it said "Build List". After waiting several minutes I tried Control-Alt-Delete and dgot "Program not responding". Eventually VW would shut down.

All 3D conversion settings are on default Medium. Vector Cacheing is "ON"; Hardware Acceleration is "OFF". CPU usage during hang-up was 50%.

This is the first time I have tried to render this drawing, but I have successfully rendered other drawings in VW 11.0. Could the VW 11.1 update be causing the rendering glitch? Any suggestions will be appreciated. Thanks,


Link to comment

JHE, you CAN globally set the "z" values for walls. There are a couple ways. The best is to set you layer "z" values. Then any wall drawn in that layer will use those values. You can also use the WALL TYPE tool (as opposed to the WALL tool) and check the "use layer z value" option. Of course each of these only work if you do it up front, before any drawing has been done.

But not to worry: To change "z" values of walls AFTER drawing them all you have to do is select all the walls (and only the walls, not any other type of object), then just change the "z" value(s) in the OIP. All the selected walls will change.

Sorry I have no ideas about the rendering issue. Maybe if you would post your system/hardware configuration (proc. speed, RAM, Video Card, etc) someone might have some clues...

Link to comment

I have had a similar problem though on a Mac. The program would quit unexpectedly during a render.

My solution was to turn off classes until I isolated the offending class. I found that there was one class that would cause the program to quit. Once I turned off that class, it rendered fine.

I do not know what was in that class that caused the problem. I have tech support looking at the file, but have not heard back from them.

Link to comment

""But not to worry: To change "z" values of walls AFTER drawing them all you have to do is select all the walls (and only the walls, not any other type of object), then just change the "z" value(s) in the OIP. All the selected walls will change.""

This is what I was trying to do, but the drawing didn't change. Thanks, JHE

Link to comment


How long do you wait when the screen "turns white" before you decide it's hung?

How much built in memory do you have?

Have you updated to SP2?""

I waited about 15 minutes, while trying various things to abort the render. My RAM is 512MB and my video RAM is 128MB. both have always been enough in the past for my simple models. Due to negative experiences recounted in this forum, I have postponed the SP2 update. The only recent update was VectorWorks 11.1 the same morning as the crash. Thanks, JHE

Link to comment

Have you updated the video driver within the past 6 months ?

Have you waited longer than 15 minutes to let the drawing render?

When it turns white, do the palettes, data display bar, scroll bars, etc all turn white also?

How many other programs are you running while VW is running?

I ask these questions because the shaded polygon mode can take ALOT of memory to process, and it can take a good bit of time to complete depending on the file size, file structure, type of objects, etc.

Link to comment


1. The computer and video card are about six months old. The original Windows driver is installed.

2. I haven't waited more than 15 minutes because it is obvious that something is wrong.

3. The whole screen turns white, except the blue VW header bar and maybe the bottom bar.

4. No other programs are running.

I tried various quick rendering modes and they all hung up. The drawing consists of 4 brick and block walls: no roof, no details, some door and window symbols and PIOs. Thanks for looking into this. JHE

Link to comment


I used the Wall Type tool on default settings to make the brick + block walls. All 3D stuff, so far, is standard VW11 objects. I will have to make some custom elements before I'm thru.

I do have an overhead door object (made with the overhead door tool) in two of the exterior walls.

I'm using VW11.1, so if the object is the culprit, it hasn't been fixed yet.

I guess I'll have to make a fake overhead door from extruded objects, and try again.

Thanks, JHE

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...