Jump to content
  • 0
Christiaan

Pan Tool doesn't stay active when pressing space bar

Question

Pressing the space bar activates the Pan Tool but only for a brief second. It's flicks back to Selection Tool almost immediately.

 

One of my colleagues has this problem and now I have it too. Any ideas?

Share this post


Link to post

10 answers to this question

Recommended Posts

  • 0

This works  -  Shut the machine down, restart it launching ONLY Vectorworks and no other applications, then test the space bar. If it works, open your other commonly used applications like your browser and email clients and see if the spacebar ceases to work after launching any of them in particular.

  • Like 1

Share this post


Link to post
  • 0

I have seen Outlook and other Office suite products cause this with the space bar specifically, normally an update from them corrected the issue within a few days. 

 

In very rare cases, resetting PRAM on Macs corr cted it as well, but I haven't needed to walk anyone through that in a very long time.

Share this post


Link to post
  • 0

If you're running Safari, try closing that.  That pretty much always resolves this issue for me, which has plagued me for a few years now, regardless of hardware, Vectorworks version, OS version, or Safari version.

Share this post


Link to post
  • 0

Mine still problematic after latest VW2019 update. Help~

Share this post


Link to post
  • 0

Google Chrome also seems to occasionally cause this problem as well.  Maybe it's any internet browser?  In any case, if I quit Chrome, the problem is resolved (even if I restart Chrome immediately afterwards).  HTH

Share this post


Link to post
  • 0

As others have mentioned, this can be caused by a key getting "stuck" in another application. I don't believe I have ever run into this; however, in my time on the support team, I know I had more than one report of it being caused by Safari. Closing Safari in those cases fixed it. Restarting Safari didn't cause it to break again.

 

If anyone notices any pattern to when the issue starts, this could potentially help in getting it fixed (assuming it is something we can fix on our end). I am constantly swapping between browsers and different versions of Vectorworks without this ever occurring, so it is probably something very specific that can cause it.

 

For what its worth, this sounds like almost the same issue that these users are running into ( https://forums.adobe.com/message/3722746 ). Similar to what I've seen, it seems restarting the browser seems to fix it there as well...

Share this post


Link to post
  • 0

Hi, I've been struggling with this for a week now and - with the long suffering help of my IT Support and Vectorworks Support - have just found the solution (or the one that worked for me at least).

 

It's similar really to the Safari fix in that it was my antivirus software that was clashing - Webroot. If you have this, there's an option you can check to prevent keyboard overriding - "Pause secure keyboard entry" in the Webroot dropdown menu. If you have the same problem but different antivirus software - look for a similar setting in this program.

 

It's become clear that the problem isn't with Vectorworks - I had this same problem across the Adobe suite of programs - but it's the result of a different program claiming rights to space bar use. Find that program and you've found the problem.

 

755562708_Screenshot2019-10-14at13_41_15.thumb.png.836bd121655694ba9a6e87ec2d434b78.png

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×