Jump to content
Milos

Windows not showing transparent

Recommended Posts

Every time I put a window in a wall in vwx18, the windows show up opaque. I've tried changing settings in the object info palette, but there doesn't seem to be anything wrong.

Share this post


Link to post

Can you post the file?

I would bet it is a class / texture issue.

  • Like 1

Share this post


Link to post

Yeah - easy fix.

You just need to set the texture for Class 'Glazing-Clear' to the glass texture of your choice.

  • Like 1

Share this post


Link to post
22 minutes ago, Kevin Allen said:

That texture should be a glass with 'portal' checked.

This is new to me.

Do not know how I missed this one.

 

Thanks for the tip.

Share this post


Link to post
23 minutes ago, Kevin Allen said:

That texture should be a glass with 'portal' checked.

 

Just now, Tom Klaber said:

This is new to me.

Do not know how I missed this one.

 

Thanks for the tip.


It's a bit sneaky, but can help environmental light spill properly into a buildings interior. I use it for all exterior glass. Theoretically it makes environment lighting calculations a bit slower, but i haven't noticed a dramatic difference in times, just quality.

Share this post


Link to post

Yeah - It appears that it is default off for all glass textures - so I am not sure I have ever seen the effects.  I will have to run some tests.  

Share this post


Link to post

1705735077_PortalTest.thumb.jpg.6a01c0537d9a16ad0fc94398410fc815.jpg

 

 

If it's anything - it's super subtle. 

 

Final Quality 

4 Bounces

Single Light

HDMI Day

Ambient On

Inclusion On

Share this post


Link to post

I find it helps most when I have a situation where I get those little light spots on flat surfaces and in tight corners, sometimes called fireflies. There are a few other things that can cause/mitigate them as well but Portals is one that seems to fix it when I have a large or nooks-and-crannies-filled indoor space with no light sources inside.

Share this post


Link to post

That is good to know - never knew how to handle those fireflies.


Thank Jim!

Share this post


Link to post
19 hours ago, Kevin Allen said:

That texture should be a glass with 'portal' checked.

HEY KEVIN,

Could you or someone elaborate on this?

I'm no getting the "portal" checked thing.

thanks,

bc

Share this post


Link to post

The "portal' option is in the texture definition, Click the "Indirect Lighting Options" button and check "Portal' to allow lighting/indirect lighting/environmental lighting to pass through the glass texture.

Share this post


Link to post
18 minutes ago, bc said:

HEY KEVIN,

Could you or someone elaborate on this?

I'm no getting the "portal" checked thing.

thanks,

bc

 

4 minutes ago, Kevin Allen said:

The "portal' option is in the texture definition, Click the "Indirect Lighting Options" button and check "Portal' to allow lighting/indirect lighting/environmental lighting to pass through the glass texture.



To clarify for anyone else reading: you do not NEED to enable that setting in order to get transparency, it just assists in letting environment lighting pass through a transparent object. Simply giving the glazing class a transparent texture should be enough to answer the original posted question.

Share this post


Link to post

OK thanks Kevin. Wow. Never really played with that one.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×