Jump to content
  • 0
mlance

Resource Availability for Everyone in Office

Question

We have a multi seat network license for Spotlight / Fundamentals. I want to create a common (on our server) location for everyone to grab symbols from so our drawings are consistent. I've made .vwx files from the default libraries of the lighting fixtures we use most often and audio symbols we use most often etc. 

I can get these to display in the Resource Manager under Favorites but this way requires coworkers to download and reinstall the files on their hard drives whenever there is a change to one of those files.

I cannot seem to get a workgroup set up (is this the best option for what  Iam trying to do?). I am confused by the file structure requirements... I am using the following:

Z:\Library\CAD\Vectorworks\Vectorworks Workgroup Files\Vectorworks 2018\Libraries\Favorites where "Vectorworks Workgroup Files" is the file location on the server.

But nothing shows up in the resource Manager after I update the User Folders within VW Options and restart...

 

Is it possible to use custom .vwx files in a workgroup?

What am I missing?

Share this post


Link to post

15 answers to this question

Recommended Posts

  • 0

I ran into this too every year again.

Please check your path in Settings.

 

E.g. if your Folder is in :

...\Vectorworks Workgroup Files\Vectorworks 2018\Libraries\Favorites

 

The path (end) in settings should read :

...\Vectorworks Workgroup Files\Vectorworks 2018

 

At least it is here that way on my Mac

Edited by zoomer

Share this post


Link to post
  • 0

@zoomer I edited the path down to just the \Vectorworks 2018... Still no dice. 

I've seen posts about having to have specific sub-folders... does this apply to favorites folders as well? 

That's why I added the "\Libraries\Favorites" part. But that doesn't work...

Share this post


Link to post
  • 0

On Mac it is called "libraries",

maybe VW is case sensitive ?

 

Maybe in Windows, you need the last Slash ?

 

Yes, the Libraries Folder seems to be needed for recognition.

(You can just copy the whole (empty) Path Structure from the User Folder)

 

I am on VW2015 only ATM.

 

EDIT :

I just saw that the Path Convention I showed to you doesn't work for my VW2015 either :)

I know it works well on my VW 2018 without any problems and it shows under

"workgroup anything" in Resource Manager, as long as not deactivated by filters or Icons

but I can't check my exact Path in Settings from here ATM.

 

Edited by zoomer

Share this post


Link to post
  • 0

When you define a Workgroup folder, you only define the top level "container" folder. The paths INSIDE that folder determine what resources can be used from the Workgroup folder.

 

To have things show up in the Favorites, you need to have nested folders inside the Workgroup folder of

 

:Libraries:Favorites

 

Inside of Favorites you need to put either the files you want to be favorites or an alias (shortcut) to that file. The files all need to be VWX files with the same version as your current Vectorworks.

 

As Zoomer said, you can copy the entire (mostly) empty hierarchy from the User folder.

 

If you want to add line styles, hatches, etc., and have them show up as default content, you have to put the file into the correct subfolder inside the Libraries:Defaults folder.

 

Based on your first post, I think you want to define Z:\Library\CAD\Vectorworks\Vectorworks Workgroup Files as your Workgroup folder. Inside of that you need a Libraries folder, and inside that a Favorites Folder. That is where you want to place the shared favorites files.

Share this post


Link to post
  • 0

Hmmm... so I set it up as you guys suggested - I copied the folder hierarchy from the user folder ...

Z:\Library\CAD\Vectorworks\Vectorworks Workgroup Files\Libraries\

And through the resource manager I can access the .vwx files that I put in  \Favorites- but not through the workgroups option - still the favorites option... If I right click on one of the files and select show in explorer - it shows it in my Vectorworks Workgroup Files folder...

Is this how that is supposed to work?

 

Also, I have a template file in 

Z:\Library\CAD\Vectorworks\Vectorworks Workgroup Files\Libraries\Defaults\Templates

But it does not show up in the option for a new file from template...

 

Nothing shows up under the workgroups icon in the resource manager (see attached)....

 

Is there another step to do to get Vectorworks to use the template in the workgroup location?

 

 

RM.JPG

Template File.JPG

Edited by mlance

Share this post


Link to post
  • 0

Have you already Updated your ressources or restarted VW to include

the new ressources ?

Share this post


Link to post
  • 0

Hmmmhhh.

 

As I know it works for me ....

Either there is still a problem with the Path (?)

or something with access/read/write rights on the server.

 

Could you try a temporary workgroup folder copy on your desktop ?

Edited by zoomer

Share this post


Link to post
  • 0

I'm pretty sure favorites always go to favorites.

 

So if you want something to show up under the workgroup section of the RM, try putting the files into Z:\Library\CAD\Vectorworks\Vectorworks Workgroup Files\Libraries\[any folder name you want].

Share this post


Link to post
  • 0

I am having issues with my workgroup folders not showing in the resource browser either. I had I configured and working and then they dissapeared with no apparent reason though not long after installing SP3. 

 

I had had previously posted this topic about the issue. Also I have contacted UK tech support but not yet received a solution from them. 

 

I need my my files in a workgroup folder instead of in favorites. As large favorite files cause considerable lag in the recourse browser. 

 

 

 

i am curious to what the problem might be here. Maybe it is the same as mine? 

Share this post


Link to post
  • 0

E.g. a Wall Styles File :

 

Create a file with your office Wall Styles,

save it with the same name as the Default VW Wall Styles File in your Workgroup Folder,

into the same VW Folder Hierarchy.

So VW will prefer your Office Style File while ignoring the Default File.

So all employees will see the Office Style File only.

 

Just make sure that there is no Style File with same name in any User Folder,

as these have priority over Workgroup Folder.

(Priority 1st User, 2nd Workgroup, 3rd VW Default App Files)

 

And set the same Workgroup Path in VW Settings for all Employee's machines.

Edited by zoomer

Share this post


Link to post
  • 0
14 minutes ago, mlance said:

How would you handle a template file that you want the whole office to use? 

 

Hypothetically if it's in the Libraries<Defaults<Templates folder, it should appear in the dropdown list when you start a new file. Vectorworks pulls this list of templates from within the Application folder, the User folder, and the Workgroup folder, all which have the same subfolder structure.

 

Make sure that the template is saved as an .sta file (via file<Save As Template).

 

If you're wanting Vectorworks to automatically open a blank file upon start-up using your template [a feature which I don't use because I more often work on existing files rather than starting new projects from scratch], go to Vectorworks Preferences < Session and turn on "Create a new document at startup". I believe the file has to be named Default.sta for this function to work.

 

728525691_ScreenShot2018-05-15at10_53_08AM.thumb.png.ab1ace37516ad6d9d416fe53321e924d.png

 

Share this post


Link to post
  • 0

Hey guys - Thanks!

Everything is working as it should.

Y'all rock!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×