Jump to content
  • 0

Modify instrument by color not working for class specific containers

Stephen Sorenson



When setting the modify instrument color to only a specific class and setting the label legend container to use lighting instrument attributes it would still color that class in the container field. (I set a copy of the container in the container symbol to use a Symbol-Color Code class so that only the channel oval fill would be color coded. I went back and tried at it's most basic level using the color field (image attached) in a brand new document and even when set to the default container class of 'None' the color coding doesn't propagate down to the container. It still propagates down if you don't modify by class but I don't like to change the color of the instruments themselves, but I like a visual identification of system locations (specifically for a designer I draft for). I used to do it with a label legend per system (using different containers) and I'd prefer not to return to that method. DId a workflow method change? I've even opened up a 2017 drawing in 2018 and the color coding that worked in 2017 doesn't come through.


This is on Spotlight 2018 Service Pack 3 Windows 10.


Link to comment

3 answers to this question

Recommended Posts

  • 0

I am experiencing varied results from this tool although not what you are experiencing. 

  1. When Lighting Instrument is checked, I cannot get any containers to change their attributes
  2. When Colour Field is checked I can get the "Use Symbol Attributes" and "Use Instrument Attributes" to work but not "Use Label Attributes"

I've submitted this as a bug on a couple of occasions over the years since it was introduced. I'll try again now.

Link to comment
  • 0

Yeah, use label attributes I've see use the pen color you set the text to in the edit label legend layout as the pen color for the container (but not the fill color).


Use symbol attributes should use whatever is saved in the container symbol and I've never had a problem with that one.


Obviously now I'm having issues with the Use instrument attributes... this tool has always been a little trial and error for me every time so I tried to double check every setting 3 or 4 time before posting here.


For reference here's the same setup in VW2017 and the containers changing how I would expect.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...