Jump to content
Grethe Connerth

Hidden Line Rendering with Objects have no Fill when Stacking Viewports

Recommended Posts

Dear VW Lovers,

 

I am creating a Viewport with Hidden Line RW Style.

 

Unfortunately the process of rendering is not possible, meaning it not only renders indefinitely but also the VW program becomes none responsive. This probably due to a lot of detail in the drawing.

As a result I have to 'Force Quit' the program and start again. 

 

After many times of trying I am now working around the issue like this:

 

Viewport on-top of Viewport

 

- splitting the drawing into multiple Viewports with different Design Layers visible

- thereafter I overlay one Viewport on-top of the other

 

--> Problem

Any objects in a Viewport are not filled.  --> Which results that you can see through all the objects on any VP.

 

 I would like to be able to create a VP that 'closes' the objects and nit the whole VP. Like when you give an object a fill through the Attributes.

Only when I give the VP a fill through the Attributes palette the whole VP becomes filled and not only the objects.

 

I have attached a screenshot of the individual Viewports and the one on the right hand side bottom holds the sandwiched Viewports.

Here it shows that all objects have no fill.

 

I would be grateful for any input and work around.

 

Cheers,

Grethe

 

 

Hidden Line Stacking Viewports.png

Share this post


Link to post

The only workaround I know of would be to give the viewports a background render of either OpenGL (lines and colours turned off) or Custom Renderworks and a foreground render of Hidden Line. I've attached an example file using OpenGL as the background render.

 

Your model doesn't look that complex so I'd be curious why it wouldn't render altogether. Perhaps you have a corrupt object.

 

Kevin

 

5ac196e88b768_ScreenShot2018-04-01at7_35_01PM.thumb.png.272bbf69cb70f9a6d7f362ba924f7948.png

Overlay Example.vwx

Edited by Kevin McAllister
Clarity

Share this post


Link to post

Hi Kevin,

 

thank you for your fast reply and also the VW Test file which was very helpful.

 

I tried your suggestions and it took a few test, I had to turn off all the Lights and also combine the Bubble Panel Walls VP with the stage VP as it didn't overlay correctly with all the walls and so forth.

 

--> new VPs attached

 

It looks good and clean, even though I was aiming for a black & white render only without the Greys from OpenGL.

Reason being as all my other explanatory Renderings are Hidden Line only.

 

Yes you have a very good point.

I was wondering this also, especially as I have other VPs with Hidden Line Renderings and they seem to be working even with all the objects in there.

 

See screenshot of a different scene / VP attached --> Hidden Line with one single Viewport

 

Maybe I have to throw away this particular VP, re-create this View into a new VP and then render it all in one with Hidden Line.

 

Cheers,

Grethe

 

 

Hidden Line & OpenGL - 1 - Stacking Viewports.png

Hidden Line & OpenGL - 2 - Stacking Viewports.png

Hidden Line one single Viewport.png

  • Like 1

Share this post


Link to post
1 hour ago, Grethe Connerth said:

It looks good and clean, even though I was aiming for a black & white render only without the Greys from OpenGL.

Reason being as all my other explanatory Renderings are Hidden Line only.

 

 

I might have a potential solution for this. Select all of the stacked viewports with the OpenGL background and click on the Lighting Options button in the OIP. Under ambient info turn up the brightness to 100%. In my test file it washes out all of the shadows. You wouldn't normally want this but because you're only using the OpenGL portion as fill it doesn't really matter.

 

Kevin

 

Edited by Kevin McAllister
  • Like 3

Share this post


Link to post

Hi Kevin,

 

Yes it did wash out all greys!  

And it shows some shadowing in the corners, which I can test and play around in the Lighting settings.

 

But you know what? I love it !!! 

It looks even better than the plain Hidden Line RW Style.

 

I rendered the Viewport showing the side view also and it did a great job.

 

Perfect ! Legend !

Thank you Kevin for this simple work around !!!

 

Grethe

Hidden Line & OpenGL - 3 - Stacking VPs & Amb Light @ 100%.png

Hidden Line & OpenGL - 4 - Stacking VPs & Amb Light @ 100%.png

  • Like 3

Share this post


Link to post
5 hours ago, Kevin McAllister said:

 

I might have a potential solution for this. Select all of the stacked viewports with the OpenGL background and click on the Lighting Options button in the OIP. Under ambient info turn up the brightness to 100%. In my test file it washes out all of the shadows. You wouldn't normally want this but because you're only using the OpenGL portion as fill it doesn't really matter.

 

Kevin

 

 

This is the technique we use to get hidden line as well !
 

Kevin beat me to it :)

 

 

  • Like 3

Share this post


Link to post

Hey Guys,

sorry to dig up a year old thread again, but how did you get the pink glow to come through in the first set of images?

It's the effect i'm after 99% of the time and would love to not have to try and mess around focusing lights if possible.

Cheers,
Jack

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...