Jump to content
tddesigner

Ghosting of hidden or deleted layers in Vision

Recommended Posts

I'm trying to use the Merge feature in Vision to separate out various components of the set for a show so that I can turn different elements on to render a 'scene' in the show to light.  I've created separate .esc exports from Vectorworks, each in their own Folder.  I then merged them into a common file with the lighting rig.  ( see the first image some lights working correctly on the "Church". )

 

When I change the property of one of the merged layers from 'True' to 'False', there is a still a ghost of the Church Mesh Shapes.  ( See the second image )

 

If I think just Delete the merged layer, I still see the ghosting but more of just a shadow. ( see the third image )

 

I have found that if I grab one of the lighting instruments in the Scene Graph and just change the focus a little with the arrow keys, the ghosting goes away.  ( See the 4th image )

 

I have many scenes in the show and, right now, the only think I can think of is to create separate files with the lighting, one for each scene. 

 

Is there a trick to refresh the rendering when I have turned the layer visibility to false? Thanks in advance. 

Screen Shot 2018-03-21 at 9.04.58 PM.png

Screen Shot 2018-03-21 at 9.05.15 PM.png

Screen Shot 2018-03-21 at 9.05.44 PM.png

Screen Shot 2018-03-21 at 9.07.25 PM.png

  • Like 1

Share this post


Link to post

Hey @tddesigner

 

This is definitely a bug. We can fix it for SP4, but we need to get you a work around for the meantime.

 

This bug is related to static vs dynamic caching of geometry. The static cache is broken. One way to resolve your issue is to move the models you want invisible into dynamic cache to work around the issue.

 

To do this, first select the MeshShapes or Layers you'd like to be invisible. Assign an XForm Universe and an XForm Address to these objects. Assign an XForm Delta Y of 5000 (inches) or something very large that will move the objects out of view. Now on your light board, ensure you are sending zero DMX to the XForm Universe and Address. To "hide" the geometry, send a value of 255. This would mimic flying out the set piece on a fly rail.

  • Like 1

Share this post


Link to post

Thanks so much. This seems to work well.  I can assign all the different components that make up each scene and assign them to a channel on the board.  I can then include that set movement in the light cues.  Some extra initial setup but will make cuing go faster. 

  • Like 1

Share this post


Link to post

Good @tddesigner I'm glad this worked for you. My apologies for it being broken in the first place but now we know it is broken so we can fix it!

 

Thanks again for your feedback and let us know if you have any other concerns.

Share this post


Link to post
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×