Jump to content
cxs

Nodes not making connections to other nodes

Recommended Posts

Sometimes, connections between nodes are not retained when I move the nodes around.

It looks as if the nodes were never connected in the first place, even though I snapped an output to an acceptable input.

 

The attached PDF shows nodes from a shared resource on the forum; I've also attached the VWX file.

 

The string input nodes are not connected to anything, but they have wires running to floating circles.  I made sure that all classes and layers are visible, so I'm certain that there aren't any hidden nodes. The wires can be unsnapped from the mysterious circles, and reconnected to a proper node.

 

This issue occurs when I copy+paste portions of a marionette network for re-use in another marionette network, or when I relocate portions of a marionette network. The issue reappears, even after connecting to the correct node.

marionette_issue_nodes-not-connecting.pdf

ODBC_v2017_v2018.vwx

Share this post


Link to post

@cxs

Hi!

I'd like to help you out with this, but first I'll need some background. (I'm the original creator of the ODBC nodes, so I'm familiar with this file.)

It looks like this file has traveled through the versions with you. When you placed the nodes on the drawing area, was that in 2018, or did you already have a network created in 2017 or 2016? We've run into issues occasionally when networks were brought forward from a previous version, but usually recreating the network from a blank file won't exhibit the same issues.

If this file was created fresh in 2018, I'd be happy to help troubleshoot further.

 

Thanks!

Marissa

Share this post


Link to post

@Marissa Farrell

 

Thanks for the speedy reply.

 

I downloaded this from the forum, for use in v2018. It came to me with "v2017".

 

I'm working on a project in a clean file, not using any nodes outside of the marionette library. I'm not having the issue now, but I did earlier today and had to delete half of the project.

I'll be sure to send you a copy when it becomes an issue again.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...