Jump to content
Shane Rowse

VW2018 Lightwright Data Exchange Glitch

Recommended Posts

I'm experiencing an odd and fairly annoying problem with Vectorworks 2018 SP2 to Lightwright 5 Data Exchange.

I've tried a number of things, including a reinstall of VW2018, testing using the demo version of LW6, changing file locations, using migration assistant to reimport my settings from 2017, running with all other software off, etc....


In a nutshell, here's the deal: I put a light on the plot, go to LW, and the unit doesn't show up, and won't, until I do one of the following: Complete export on exit, move it to a different position, or manually enter an attribute like unit number, purpose, or color. Refresh instruments has no effect.


Once LW is communicating with VW about the instrument the following problem crops up: if I move the unit from one position to another, the position lags one position behind. In the VW Obj. Info Palette the position info stays correct, but on LW it doesn't update until the second time it gets moved. So, if I move from Pipe A to Pipe B, VW shows Pipe B, but LW still shows Pipe A. Move back to Pipe A, VW keeps it right but LW lags one behind and shows Pipe B. Again, editing an attribute, moving the unit, even to the same pipe that it's on, or doing a complete export, corrects the problem, but it comes back as soon as a unit gets moved.


Export the same file back to VW 2017, Quit 2018, open in 2017, no problem, everything is as usual, works like a charm. Seems like this is something on the VW side rather than on the LW side. Something's getting screwed up in the process of VW writing the .xml file, I assume.


Long boring demo screen recording attached....

Anybody else seen this and figured out how to fix it? It's not like it can't be worked around but it's annoying enough that I'm just running 2017 to avoid it.


Share this post

Link to post

I'm seeing the same thing with LW6.  Any data that isn't edited via Object Info does not send to Lightwright immediately.


As a side note, LW5 is not officially supported with Sierra and High Sierra.  There are some significant file system changes with High Sierra, and you may experience data loss with software that has not been updated to be compatible.


Share this post

Link to post

Yeah, I know about the Sierra incompatibility, and have been getting ready to upgrade; trying LW6 demo was the first thing I tried to when trying to suss this out. 

Glad I'm not seeing things ;-).

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


    • 7150 Riverwood Drive
    • Columbia, Maryland 21046, USA
    • Contact Us | 410.290.5114


  • © 2018 Vectorworks, Inc. All rights reserved.
  • Vectorworks, Inc. is part of the Nemetschek Group.