Jump to content
halfcouple

screen plane only

Recommended Posts

That's an old topic, but still not solved:

 

- setting the layer plane options to "screen plane only"

- setting document preferences to "screen plane only"

- saving the file as template

 

open a new template file: Layer plane setting is on "Layer"

 

Help file sais:

"The selected planar mode remains in effect until the next time it is changed."

 

This is not working. Screen plane setting seems not to be stored and kept during a session at all.

 

 

Share this post


Link to post

Hey. The curse of every working day. I have recently (re) raised this as a bug via VW UK. However - not ideal I know - but if you go: File/ document preferences/document settings/set the plane mode to screen plane only it defaults back to screen plane mode (after layer plane operations) for your session (or at least it does on my programme (VW2018 Architect SP2/Windows 10)  However if I attempt this same operation through the tab pane below (to the same destination) I find it is far less stable and does not default back to screen mode after layer plane operations.  I'd be interested if you experienced the same thing? Apologies for another rambling post! Cheers D 

image.png

Share this post


Link to post

Always really great to get collaberative feedback, or any feedback at all actually. When you are ready anyone......

Share this post


Link to post

Gentlemen,

   I posted this as a bug on January 1st. I was informed it is (or will be fixed) in a future release, but I don't know which one. Hopefully the next one. I was able to determine through testing that the bug only affects files saved in VW 2018, as files saved in VW 2017 open correctly in both VW 2017 and VW 2018.

 

   If you use a particular template file often, you could export it to VW 2017, resave it as a template file in VW 2017,  then move the .sta file to your VW 2018 User Folder under the "Vectorworks/2018/Libraries/Defaults/Templates/" directory. Save your VW 2018 version of the .sta file in another folder. Of course if you already have a template file in VW 2017, you can drag a copy of it to your 2018 User Folder.

 

   As soon as the bug fix is released you can replace your template file to the VW 2018 version again. This won't correct the problem when you save and reopen regular files, but at least you'll start a new file correctly.

 

HTH,

Raymond

Share this post


Link to post

After having again spent a lot of time correcting 2D move by point operations that were accicdently made in Layer plane modus I wonder again if this inexpressively horrible nuisance will ever be corrected.

But meanwhile, as a workaround (until release VW2028, which I suppose will finally have this bugfix... 😉 ) , maybe it is possible to have a script that sets the option back to "screen plane only" by one shortkey instead of the 4 clicks 'screenplane/options/screenplane only/ok' ? Anyone knows how this could work ? Another workaround could be if this setting is somehow saved together with a saved view ?

Share this post


Link to post

I am not suffering with this as much after SP2/3 2018 but yes previous files need to be re-adjusted and we work on over 40 projects a year so it is a bit of a pain! Gets even worse if you do a lot of rendering as any 2d (accidentally 3d) objects mess with the render and you have to go back and change it all to 2d (screeen plane) 😞

Share this post


Link to post

Hi, I use a Plugin that i received from the forum ages ago to either place all the items in the file on screen plane or on layer plane.

HTH

The instruction are in under documentation in the file.

PlaneMode (1).zip

Share this post


Link to post

halfcouple,

   This is an old issue, and I remember answering it before. What I didn't remember was how long ago I posted a response. See this post from 7.5 years ago. 

 

 

   Since my post, I added another line to BEEP when the preference is set to TRUE. This lets you hear an audible BEEP when the "Active Plane Menu" gets set to "Screen Plane", and nothing when it gets set to "Layer Plane".  Click reduction AND Glance reduction rolled into one.

 

{ This script will toggle the "Active Plane Menu" between "Screen Plane" and "Layer Plane", }
{ and BEEP when "Screen Plane" is active. }
{ 23 Apr 2011 - Raymond J Mullin }

SetPref(1099, not GetPref(1099));
if GetPref(1099) then SysBeep;

   If the last option in the "Plane Mode" dialog is selected, "Screen Plane or Working Plane", then my script toggles the "Active Plane Menu" between "Screen Plane" and "Working Plane".

 

   If anyone needs help turning this into a Menu Command, please write back.

 

HTISH,  (Hope This Is Still Helpful),

Raymond

 

Share this post


Link to post

Thanks for all your help !

The script seems to do exactly what I need :-)

 

I have to correct myself,- since SP 3 the problem that files do not keep the setting to 'screenplane only' after closing seems to be solved.

Anyway, I still do not understand precisely when the program decides to switch to 'Layer plane' or  'Screen aligned' ignoring of what is set in the documents preferances. Is this only when 2d Objects that are in 3D plane are moved or otherwise operated ? Can't find any fixed rules for that, is it arbitrarily, or is that what people call A.I. ? 😉

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×