Jump to content
112090006

Marionette Script deletes class "0" in custom file template

Recommended Posts

Hi All-

 

     I've recently joined an architectural  firm that has primarily been working with Vectorworks' 2D features for project documentation for the past few years- this summer and fall the leadership will be making an effort to incorporate some of Vectorworks' 3D and BIM capablities into our workflow. I have a great deal of experience working in Revit and with Rhino/grasshopper, and I have really been enjoying learning Marionette. I am planning to introduce my co-workers to some of the scripts I've been working on to automate drafting tasks and calculations soon, but I have been having issues with the  class structure in our project template file whenever I run a marionette script inside one of our documents. In the firm's template, the default "NONE" class has been replaced by "0". this is the default class for all symbols and groups. When I run a script in one of our template files, the "0" class  is deleted and the "None" layer is created. The symbols and groups assigned to class "0" are still visible, but cannot be selected, and the class assignment in the object info panel is blank. Since they cannot be selected they cannot be reassigned to class "None" or any other class. When I force select or attempt to edit those groups and symbols, all of the symbols in the drawing then are deleted. I suspect that the template file's renaming of the "none" class to "0" is causing a conflict of some sort, but I'm not sure if it's necessary to change the template files' class structure in order to fix the problem. Any insight on this problem? 

Share this post


Link to post

I can tell you that when building templates, we STRONGLY recommend to leave the None class as None. There are a lot of different instances where the None class will be recreated even if you change its name, apart from scripts specifically. If it is important for your office to change the None class to 0, you can do this by mapping your classes to the AIA/NCS standard. Go to File > Document Settings > Standard Naming and choose AIA/NCS. This will set your None class to 0 and set your Dimension class to A-ANNO-DIMS. If you don't check "Enable Auto-classing" you can still use all of your office standard classes.

 

5a7b6649ce759_ScreenShot2018-02-07at3_46_02PM.thumb.png.6eb2e3ec0bc016ce2ec39767df165f71.png

 

hope that helps,

-Sarah

 

 

Share this post


Link to post

Hi @Marissa Farrelland @sbarrett,

 

i have  exactly the same issue in my office. In random, the Marionette Objects delete the ‘0” class and than for us it is impossible to understand if we miss some information.

 

as a work around we are trying to get rid of all “0” class elements in our base drawings, but as this is a standard layer/ class in Autocad users, every time we import some drawings from external suppliers, the “0” class apears again. 

 

I confess this is a UGE issue because we can not use Marionette Objects , and being always afraid that data will be lost.

 

and please not that we have the “NONE” class.

 

please advise what is the solution !

 

my major problem to implement MARIONETTE objects in the workflow is this kind of Bugs.

 

thanks in advance for your support 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×