Jump to content

Installer fails due to low disk space, but there is more than enough

Recommended Posts

  • Vectorworks, Inc Employee

Does it give the same error if you select C:\Users\YOURUSERNAME\Desktop and attempt to install it there, does the same error occur?

If so, I suspect it may be a permissions issue throwing up the wrong error, as both you and the dxdiag have confirmed plenty of free space on all drives. In that case, contact tech@vectorworks.net and they will likely check your folder permissions to see if the installer is being stopped somewhere along the way.

A few quick things to try in the meantime as well:

Disable ANY active malware of antivirus application, as they can sometimes cause things like this.
Throw away the installer you have currently, empty the recycle bin, and then download it again. Its pretty unlikely the installer was corrupt and still managed to get this far, but its a possibility.

Link to comment
  • 2 months later...
  • 8 months later...

Hi @bcarrigg90 and @AJ Roslevich, I provide Tech Support for Vectorworks users in New Zealand. Currently I have a Windows 10 user experiencing this issue with Vectorworks 2018 which is highly unusual. We need to know what resolved this matter for you. Can you please tell us what worked for you? 


Here's what I've confirmed on my user's computer: 

  • The installation program doesn't load the default location automatically, but does permit it to be manually selected
  • C drive permissions are the same as mine / should work
  • Program Folder permissions are the same as mine / should work
  • There is 50GB of space available on C drive
  • Antivirus seemingly not interfering (although I won't rule it out. MalwareBytes)
  • Latest, freshly-downloaded SP5 installer still affected


Can you please advise what worked for you? 


@MMajor124 and @Jim Wilson, based on this discussion I suspect this the storage type of the disk/partition might be a factor. See basic vs dynamic storage types. To determine a disk type, open 'Disk Management' and look at the 'Type' column for the applicable volume. I expect the solution will be to format the volume/partition back to the 'basic' type.

Edited by Jeremy Best
Revisions and clarifications after new insight.
Link to comment

Tech Support in the USA has advised this has been fixed by one of a few different things for different users. They have also confirmed that Vectorworks installers should be compatible with 'dynamic' volumes/partitions, so ignore my prior comment.


Previously successful remedies have included: 

  • Trying the same installer again
  • Re-downloading the installer. (The same one or a newer Service Pack if available)
  • Extracting the installer using an alternative decompression program. (I've encountered trouble with WinRar in the past where it presented a [different type of] error while extracting a Vectorworks installer, but extracting the same zip with 7-Zip didn't present any issue). Alternatives include: 
    • Windows Explorer extraction (Windows default)
    • 7-Zip

Please update this thread with what remedy works for you. Thanks! 

Link to comment

Thanks for the update @AJ Roslevich.


So far this has only occurred on computers that have hard drives with multiple partitions/volumes. Do you have multiple partitions/volumes on your hard drive? if you're not sure you can use the Windows utility called 'Disk Management' to determine: 

  • How many 'Disk 0' items are listed. (On Windows 7, 8.1 & 10 use Run and type 'diskmgmt.msc' and click OK). 
  • The 'Type' of every volume for 'Disk 0' and 'Windows 8' 

I'm requesting what type just in case it is a factor in your case, although I've been informed Vectorworks installers should be compatible with 'dynamic' partitions. (See prior post for more info). 

Link to comment

Okay, so I've now had confirmation from two users that the following process gets around this issue: 


Vectorworks engineers prescribed the following sequence to me, but I've expanded it to suit multiple scenarios.



If you only have the default Windows extraction capability you may have to download an aftermarket extraction program such as 7-Zip or WinRAR. This process will differ slightly depending on what extraction program you have but the main idea is to extract the 'internals' of the 'Vectorworks 20XX Installer' application to reveal the prior/alternative installer program inside. It seems at least wise (and might actually be necessary) to extract these internal pieces into it's own folder, preferably of the same name and in the same location as the 'Vectorworks 20XX Installer' application (see second image below). If you’ve already got the Vectorworks Installer zip file and unzipped/decompressed it you can start at step 3. 



  1. Download the Vectorworks installer .zip file (if you haven't already).
  2. Extract the downloaded .zip. - Don't double-click it. Right-click and extract it to avoid potential issues.
  3. Inside of the extracted information locate the ‘Vectorworks 20XX Installer’ application (that you'd normally open to begin the installation).
  4. Right click on the ‘Vectorworks 20XX Installer’ program and choose to extract it. - This process will be different depending on which extraction program you have installed. The idea is to extract the contents of the ‘Vectorworks 2019 Installer’ program into a folder of the same name, in the same location (as pictured below) so depending on which extraction program you have, you might need to open the full program to see all options.
    • Just in case it matters, DO NOT use any option called ‘Extract Here’ as it will vomit all the internals into the current folder.
    • If using 7-Zip choose, ‘Extract to Vectorworks 2019 Installer\’ as pictured below which creates the namesake folder for you into which it will put the extracted internals.
    • If you have WinRAR installed its equivalent option might not be in your contextual menu, in which case open the WinRAR program to access this option or to add it to your contextual menu options.
  5. Once extracted you might end up with either of these file paths. Open these folders to access the prior/alternative installer: 
    • \win-unpacked\resources\installer, OR 
    • \Vectorworks 2019 Installer\resources\installer (See this result pictured below).
  6. Launch the “Install Vectorworks20XX.exe” found in the folder named ‘installer.’
    • It will launch with the old installer interface and go through without the ‘not enough space’ error.

If you encounter any issues or circumstances that reveal issues with the above instructions please reply with those here for the benefit of all and I'll seek to address them. 







Edited by Jeremy Best
Correcting mistakes for sake of clarity
  • Like 1
Link to comment
  • 3 weeks later...

@Jeremy Best

I really appreciate the info but unfortunately, this isn't working for me. I've downloaded multiple times, unzipped with 7zip, Winrar, and Winzip and still I get the warning saying I don't have space. I do indeed have space, 150GB in fact. I have contacted my VW tech support directly and am waiting to hear back. Thanks again for your efforts. I'll post a solution if I find one.

Would love to hear from @AJ Roslevich if he/she was able to get a better result.

Edited by jakez
Link to comment

@jakez I was able to get VW2018 installed by following the instructions posted above. In case it's not clear, you have to extract the installer from the zip folder you downloaded, then find the file named "Vectorworks 20XX Installer" and extract that, as well. There are two levels of extraction.

For the record, the computer I installed on is a Windows 8 PC, and I used 7-Zip for the extractions.

  • Like 1
Link to comment
On ‎1‎/‎4‎/‎2019 at 4:33 AM, jakez said:

@AJ Roslevich Yes I think I followed those instructions to a tee; still no dice. The one piece that was missing for me was finding the old version of the installer. It is located within the unpacked folder/resources/installer folders. VW tech support helped me with and had it going tickity-boo in no time.


This is THE SOLUTION for the "Not enough space" installer problem.


I had the same issue with upgrading 17 to 19 and this did the trick. I would guess there is some issue in installer skin of the original installer.

  • Like 1
Link to comment
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...