Jump to content
  • 2
Cookie_NZ

Prefixes to Label Legends - Spotlight

Question

Hello all,

 

It would be great to be able to add a prefix to an attribute in a Label Legend which doesn't appear in the data field.  So a channel field could have a "#" before it, the address could have "DMX:" before it etc.  It would be great if these responded to the font/colour/size of the associated attribute.  

 

These prefixed can of course currently added to the attribute fields directly, but then create issues when working with Lightwright data exchange.     

 

Regards,

 

Cookie

Share this post


Link to post

6 answers to this question

Recommended Posts

  • 0

Good idea. 

As a workaround you could add the prefix text as a container object or to any of the existing container shapes. 

Share this post


Link to post
  • 0

HI Mark,

 

Thanks for the suggestion.  I'm using that currently as a workaround.  But the problem is the # in the container needs a different offset depending on if the channel is in the 10's 100's or 1000's.  So workable but starts to add to the number of label legends required to make a plan work.  But yes, it's the best workaround I know of at the moment. Thanks!

 

Regards,

 

Cookie

Share this post


Link to post
  • 0

Hi Mark,

 

Thanks for taking the time to look at this.  The issue I have is many of the lampies I work with are, shall we say of a certain age... So large numbers on the plan are appreciated for eyesight that's not what it once was.  Particularly when printing plans for arenas/exhibition halls when it's helpful to get a large area on an A1/A0 plan.

 

So if I offset the channel numbers so they read well for 2 digits, they rather over-shoot the instrument with 4 digits.  This issue is further compounded when it's a busy truss and the attributes start to clash with each other.  The ideal would be to keep the attribute and prefix centred over the instrument.  

 

5a44c60364105_ScreenShot2017-12-28at10_21_50.thumb.png.a4e3fc21d214301f639ea10b20c07b60.png

 

Regards,

 

Cookie

Share this post


Link to post
  • 0

Agreed, you will have to adjust the label position. Your signature suggests you are 2010 so you won't have this feature, but now the eyedropper tool will paste label legend position properties to other instruments. (see below)

 

 

There is a brilliant menu command in Sam Jones's AutoplotVW set of commands that has a "Copy Altered Labels" script which is potentially more use as it copies the legend type as well.

 

These are all workarounds. I completely accept that a prefix solution would be really useful especially as, since the label legend tool was introduced, labelling for instruments possibly needs to be more "intricate".

Share this post


Link to post
  • 0

Hi Mark,

 

Thanks for making the video.  I wasn't aware of that function in the eyedropper.  Really useful to know.  

 

I've been using the Spotlight/Label Legends/Create Legend from instrument command a great deal.  Another really fantastic function in my opinion.  

 

I'll admit I don't make enough use out of Sam's LL macros.  Certainly wouldn't be without AutoplotVW.  A great set of additional tools. 

 

I've also been in touch with John McKernon to see if Lightwright could cope with having a # as part of a channel prefix.  He says not at the moment, but I'm welcome to add it to the request list for LW7.

 

Thanks again for the help.  I guess it's workarounds until a better solution comes along.

 

 

Cheers,

 

Cookie 

 

(I'm on 2018.  Not sure where it says 2010?  That was when I started with VW).

 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×